Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help



Go Back   PeachParts Mercedes-Benz Forum > Mercedes-Benz Tech Information and Support > Diesel Discussion

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 02-23-2011, 09:13 PM
PRO VEGGIE CONVERTER
 
Join Date: Feb 2005
Location: Santa Maria CA 150mi North of LA
Posts: 677
1983 300SD starting issue

1983 300SD was brought to me to replace the ignition switch becasue it was getting hard to open. Customer had already had the tumbler replaced a year ago with a dealer part. I suggested to replace the ignition assembly w/ electrical portion and the tumbler. When he brought me the car last week, the battery light was staying on when when the key was removed, and the battery would drain(I have seen this before on other cars with faulty ignition switch). I disconnected the battery and charged it. Today I installed the new parts and the starter is not getting power. I tried the old switch and same issue. I tried a known good used switch and same story. I can start the car by energizing the starter directly. Also tried unplugging the alternator, and it does make the battery light turn off, but still no ignition. What should I look at next?

__________________
Andrew Villasenor
805-720-5057
1984 300D turbo 5-speed manual(daily driver)
ALL MY DIESELS RUNNING WVO
Everything is for sale for the right amount
Ebay Store
Reply With Quote
  #2  
Old 02-23-2011, 09:41 PM
vstech's Avatar
DD MOD, HVAC,MCP,Mac,GMAC
 
Join Date: Mar 2006
Location: Mount Holly, NC
Posts: 26,389
neutral safety switch.
shifter bushings, worn or missing will prevent Park from engaging the switch. push the shifter all the way forward and to the right... I bet it starts.
__________________
John HAUL AWAY, OR CRUSHED CARS!!! HELP ME keep the cars out of the crusher! A/C Thread
"as I ride with my a/c on... I have fond memories of sweaty oily saturdays and spewing R12 into the air. THANKS for all you do!

My drivers:
1987 190D 2.5Turbo
1987 190D 2.5Turbo
1987 190D 2.5-5SPEED!!!

1987 300TD
1987 300TD
1994GMC 2500 6.5Turbo truck... I had to put the ladder somewhere!
Reply With Quote
  #3  
Old 02-23-2011, 09:43 PM
vstech's Avatar
DD MOD, HVAC,MCP,Mac,GMAC
 
Join Date: Mar 2006
Location: Mount Holly, NC
Posts: 26,389
for the battery light, replace the alternator/regulator and see if the problem goes away.
__________________
John HAUL AWAY, OR CRUSHED CARS!!! HELP ME keep the cars out of the crusher! A/C Thread
"as I ride with my a/c on... I have fond memories of sweaty oily saturdays and spewing R12 into the air. THANKS for all you do!

My drivers:
1987 190D 2.5Turbo
1987 190D 2.5Turbo
1987 190D 2.5-5SPEED!!!

1987 300TD
1987 300TD
1994GMC 2500 6.5Turbo truck... I had to put the ladder somewhere!
Reply With Quote
  #4  
Old 02-23-2011, 09:50 PM
Registered User
 
Join Date: Sep 2001
Location: central Texas
Posts: 17,277
Quote:
Originally Posted by vstech View Post
for the battery light, replace the alternator/regulator and see if the problem goes away.
Uh.. is there any possibility that the diode or resister in the sensor circuit for that light is faulty ? or perhaps a transistor ?
Reply With Quote
  #5  
Old 02-23-2011, 09:56 PM
vstech's Avatar
DD MOD, HVAC,MCP,Mac,GMAC
 
Join Date: Mar 2006
Location: Mount Holly, NC
Posts: 26,389
isn't all that in the alternator?
I know SQUAT about instruments and their function... just what fixes em!
he said that unplugging the alt turned out the light.
diode is in the alt, and a replacement regulator MIGHT fix it!
I'd plug in a good alt and see if the light goes out. our alts are SOOOO easy to wire in. one push in plug! great. plug in a good alt, and set it on the bracket. light off, golden!
__________________
John HAUL AWAY, OR CRUSHED CARS!!! HELP ME keep the cars out of the crusher! A/C Thread
"as I ride with my a/c on... I have fond memories of sweaty oily saturdays and spewing R12 into the air. THANKS for all you do!

My drivers:
1987 190D 2.5Turbo
1987 190D 2.5Turbo
1987 190D 2.5-5SPEED!!!

1987 300TD
1987 300TD
1994GMC 2500 6.5Turbo truck... I had to put the ladder somewhere!
Reply With Quote
  #6  
Old 02-24-2011, 12:56 PM
Registered User
 
Join Date: May 2007
Location: Out in the Boonies of Hot, Dry, Dusty, Windy Nevada
Posts: 9,585
I had a problem with the battery light staying on with the key removed. engine started ok though.

problem was the ground strap, body to engine. removed it cleaned the contact surfaces, and all has been good.

Charlie

__________________
there were three HP ratings on the OM616...

1) Not much power
2) Even less power
3) Not nearly enough power!! 240D w/auto

Anyone that thinks a 240D is slow drives too fast.

80 240D Naturally Exasperated, 4-Spd 388k DD 150mph spedo 3:58 Diff

We are advised to NOT judge ALL Muslims by the actions of a few lunatics, but we are encouraged to judge ALL gun owners by the actions of a few lunatics. Funny how that works
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On




All times are GMT -4. The time now is 11:05 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2020, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2018 Pelican Parts, LLC - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page