Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help




Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Diesel Discussion

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 04-05-2011, 03:20 PM
Registered User
 
Join Date: Dec 2010
Posts: 13
96 E 300 diesel. Defective Harness or K-40 relay

Had posted several months ago. Car stalls every week or so. All lights flash near speedometer after car restarts. Only stops running when going under 40 or much less. Lights flash on mirror the red and green. Sometimes the check engine stays on for days then disappears. When attempting to restart after stalling the check again light will not come on when starting. It is a normal process for it to show but disappears after it starts Other than Mercedes all the so-call certified mercedes shops will not look at it. The stalls are getting longer whereas it takes longer to restart. This problem from December had stopped in early Jan. but is now starting again. Majority of the time the car stops when I am hardly moving,just shutters and stops. Any thoughts on whether this is a Harness or K-40 relay problem.
Reply With Quote
  #2  
Old 04-05-2011, 05:01 PM
Registered User
 
Join Date: May 2007
Posts: 746
Quote:
Originally Posted by alienkeeper View Post
Had posted several months ago. Car stalls every week or so. All lights flash near speedometer after car restarts. Only stops running when going under 40 or much less. Lights flash on mirror the red and green. Sometimes the check engine stays on for days then disappears. When attempting to restart after stalling the check again light will not come on when starting. It is a normal process for it to show but disappears after it starts Other than Mercedes all the so-call certified mercedes shops will not look at it. The stalls are getting longer whereas it takes longer to restart. This problem from December had stopped in early Jan. but is now starting again. Majority of the time the car stops when I am hardly moving,just shutters and stops. Any thoughts on whether this is a Harness or K-40 relay problem.
I don't believe the 96 model had the same harness problem that the earlier years did, and from a standpoint of cost and labor, the K-40 relay would be my first choice. Many of the issues you write about can be caused by a failing K-40 relay, so I think it would be worth a shot to replace it and see what happens. Good luck...
__________________
96 E300d
Reply With Quote
  #3  
Old 04-06-2011, 01:11 PM
Registered User
 
Join Date: Dec 2010
Posts: 13
Thanks for your reply. I was at Mercedes yesterday and we found leaking lines around the fuel filter. The tech mentioned that as the lines get worse more air will be sucked into lines thus causing stalls. This was viewed by a technician who volunteered his time. I was picking up the Mercedes ornament which was recently broken at the car wash. Maybe this problem IS THE LEAKING LINES
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On




All times are GMT -4. The time now is 02:24 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page