Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help



Go Back   PeachParts Mercedes-Benz Forum > Mercedes-Benz Tech Information and Support > Diesel Discussion

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 05-01-2011, 02:31 PM
Registered User
 
Join Date: May 2011
Posts: 2
1992 300SD

I just bought a 1992 300SD with 232,000 from the original owner - for $7,500. I made the mistake of not having the car checked out by certified tech. I did Carfax check and everything was clean and the car exterior is in perfect condition and I got over $13,000 worth of service records with the car - includes blower motor, new radiator, engine mounts, new AC comp, linkage and numerous other fixes over the years -BUT when I test drove the car I did not "push" the engine. I found out on my first trip up the highway that it has very sluggish acceleration especially on the smallest hill. It has a turbo but the car does not seem to kick into any sort of overdrive and if I push the pedal to the floor it does nothing -the car slowly accelerates.It runs about 3200 RPM at 75-80MPH. I had the fuel and air filters changed and had a local Mercedes tech check vac lines and he said he could not find anything wrong on the air/fuel side but he felt like there was something causing the lack of acceleration. He thought it might be a CDU unit - that was first introduced in 1992 and is checking on finding a unit. He said this was an expensive fix -and charged me $563 any the car is still not fixed.I reliaze I made a mistake but I really love this car but can't afford to pump $1000's into a vehicle that already has over 200k miles on it. Any suggestions on what to look for -so I can bring the car to someone else who might be able to fix it in the central Mississippi area.

Reply With Quote
  #2  
Old 05-01-2011, 02:47 PM
TylerH860's Avatar
KHAAAAAAN-gress
 
Join Date: Aug 2007
Location: Wichita, Ks
Posts: 5,188
Google "mercedes" and "rodbender"

Mercedes like money; if you can't do the bulk of the work yourself you will be spending thousands on the car, easily.

How did he rule out lack of fuel?
__________________
1985 500SL Euro w/ AMG bits 130k
1984 300SD Turbodiesel 192k
1980 240D Stick China 188k
2001 CLK55 AMG 101k
2007 S600 Biturbo 149k Overheated Project, IT'S ALIVE!!!
Reply With Quote
  #3  
Old 05-01-2011, 04:28 PM
vstech's Avatar
DD MOD, HVAC,MCP,Mac,GMAC
 
Join Date: Mar 2006
Location: Mount Holly, NC
Posts: 26,389
this sounds like classic fuel filter clogging, or alda out of adjustment.
I gotta know what this clown did for 500!

oh, and WELCOME to the mercedes forum!
__________________
John HAUL AWAY, OR CRUSHED CARS!!! HELP ME keep the cars out of the crusher! A/C Thread
"as I ride with my a/c on... I have fond memories of sweaty oily saturdays and spewing R12 into the air. THANKS for all you do!

My drivers:
1987 190D 2.5Turbo
1987 190D 2.5Turbo
1987 190D 2.5-5SPEED!!!

1987 300TD
1987 300TD
1994GMC 2500 6.5Turbo truck... I had to put the ladder somewhere!
Reply With Quote
  #4  
Old 05-01-2011, 11:09 PM
Registered User
 
Join Date: May 2011
Posts: 2
92 300SD

I spoke to tech again today - he said the turbo is not kicking on and he is looking for the electronic control unit. He said he has serviced the vehicle for years and the previous owner was alerted to lack of power issue and choose not to pursue a fix...........what would cause the turbo not to kick on?It is not getting a signal of some kind - yet the turbo spins freely and is functional.
Reply With Quote
  #5  
Old 05-01-2011, 11:16 PM
vstech's Avatar
DD MOD, HVAC,MCP,Mac,GMAC
 
Join Date: Mar 2006
Location: Mount Holly, NC
Posts: 26,389
I am unfamiliar with the electronic turbo control you speak of.
perhaps someone on here more familiar with your model will chime in.
turbo builds pressure with added fuel to the combustion process, under load. the wastegate releases exhaust pressure, by a setpoint, and the alda reduces fuel when turbo pressure is reduced.
if one of these controls is malfunctioning, you will have a lack of power.
IF he's been servicing it for all this time, why did he charge you 560 to diagnose a problem he was already aware of?
__________________
John HAUL AWAY, OR CRUSHED CARS!!! HELP ME keep the cars out of the crusher! A/C Thread
"as I ride with my a/c on... I have fond memories of sweaty oily saturdays and spewing R12 into the air. THANKS for all you do!

My drivers:
1987 190D 2.5Turbo
1987 190D 2.5Turbo
1987 190D 2.5-5SPEED!!!

1987 300TD
1987 300TD
1994GMC 2500 6.5Turbo truck... I had to put the ladder somewhere!
Reply With Quote
  #6  
Old 05-01-2011, 11:22 PM
Daman858's Avatar
Registered User
 
Join Date: Sep 2010
Location: At the beach, Pawleys Island, SC
Posts: 198
I am by no means knowledgeable about your model car, but I would advise you not to panic or worry because you will get a lot of help here and we will make sure that your car will run properly. Maybe the turbo boost waste gate is stuck open...happened to my Ford truck turbo diesel. Also, I was under the impression that the 3.5 engine was the "rod bender", not your 3.0.

If the PO knew about this problem and didn't tell you about it, he needs a call from you.

Here's a note from the Good MB Shop section if you are anywhere near Richland, MS Richland, MS
__________________
"Life is tough...it's even tougher if you're stupid." John Wayne


Dave
Pawleys Island, SC

'79 300CD

Last edited by Daman858; 05-02-2011 at 08:05 AM.
Reply With Quote
  #7  
Old 05-02-2011, 12:41 AM
TylerH860's Avatar
KHAAAAAAN-gress
 
Join Date: Aug 2007
Location: Wichita, Ks
Posts: 5,188
It sounds like an imaginary part to me. I would think the turbo is still controlled the good old fashion vacuum way with them.

Your symptoms are classic fuel starvation. If he charged more than an hour or two labor to change your fuel filters and look things over you got ripped off big time.

I'm just curious how he ruled out fuel starvation.
__________________
1985 500SL Euro w/ AMG bits 130k
1984 300SD Turbodiesel 192k
1980 240D Stick China 188k
2001 CLK55 AMG 101k
2007 S600 Biturbo 149k Overheated Project, IT'S ALIVE!!!
Reply With Quote
  #8  
Old 05-02-2011, 01:32 AM
Registered User
 
Join Date: Sep 2006
Location: Middle TN
Posts: 3,827
Quote:
Originally Posted by MsOwner View Post
I spoke to tech again today - he said the turbo is not kicking on and he is looking for the electronic control unit. He said he has serviced the vehicle for years and the previous owner was alerted to lack of power issue and choose not to pursue a fix...........what would cause the turbo not to kick on?It is not getting a signal of some kind - yet the turbo spins freely and is functional.
Looks like PO is a thief and mechanic is incompetent. Mechanic should KNOW where stock parts are located. It sounds suspiciously like a muffler bearing that some guy tried to sell my wife. Regardless, likely not a complicated item and someone with one of these particular cars will chime in. Don't pay for a mechanic throwing parts at a problem without properly diagnosing. Proper install of needed parts is why they get the big bucks. Anyone can install the wrong part or the correct part improperly.
__________________
85SD 240K & stopped counting getting paint. 84SD 180,000. Probably up for sale in the fall 2020. 85TD beginning to repair to DD status.
Reply With Quote
  #9  
Old 05-02-2011, 01:59 AM
compress ignite's Avatar
Drone aspiring to Serfdom
 
Join Date: Feb 2004
Location: 32(degrees) North by 81(degrees) West
Posts: 5,554
I'm not suggestin,Mind You...

1.Find a Real Mercedes Mechanic. (Not a Thief,with a Wrench in his hand)

2.Y'all gots any them Homies that like to make funny signals wif der hands?
(If "Someone" were to make a contribution to their "Widows and Orphans"
fund,the Previous Owner MIGHT find his New Ride less than Bling.)
__________________
'84 300SD sold
124.128
Reply With Quote
  #10  
Old 05-02-2011, 10:14 AM
amg280's Avatar
Registered User
 
Join Date: Apr 2002
Location: NY
Posts: 530
He does have the 3.5, not the 3.0, so it is a "rod bender". But if it lasted this long without bending, its possible he is out of the woods...

When I got my 93 turbo, I had the same problem. No turbo. First, I replaced the OVP relay. That fixed it. Then, a year later, the turbo never spooled up again. This time, the computer was shutting it down (leaving wastegate open). This was because the EDS computer detected a vacuum leak in the EGR system. I decided to do what many on this forum did with the 300D's of this genre. Yank to stupid computer controlled system out and install a normal pressure regulated (spring) wastegate. That also disabled the stupid EGR. I assuming the 300SD might have the same "type" of system, but I have never seen one up close. Good luck. It could be something simple. When my turbo shutdown, It struggled to get to 60 on flat ground.

__________________
93 300D 2.5 Turbo, Black/Palomino 273K
09 E350 Black/Black 41K
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On




All times are GMT -4. The time now is 05:54 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2020, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2018 Pelican Parts, LLC - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page