Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help



Go Back   PeachParts Mercedes-Benz Forum > Mercedes-Benz Tech Information and Support > Diesel Discussion

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 05-08-2011, 12:21 AM
Registered User
 
Join Date: Jul 2010
Posts: 49
Glow plug relay not turning on?

i check that there is power going to it and power on both sides of the fuseable link. all fuses in the fuse box are good. i also swapped out a known good relay and still doesn't work. what else can i check?

thanks.

Reply With Quote
  #2  
Old 05-08-2011, 01:57 AM
Unofficial wormcan opener
 
Join Date: Dec 2005
Location: Ashland, MA
Posts: 2,602
You could try posting the year and model or fill in your signature.
__________________
1987 300TD 309, xxx 2.8.2014 10,000 mile OCI


Be careful of the toes you step on today, as they may be connected to the ass you have to kiss tomorrow. anonymous

“Be who you are and say what you feel, because those who mind don’t matter, and those who matter won’t mind.” Dr. Seuss
Reply With Quote
  #3  
Old 05-08-2011, 03:13 AM
Registered User
 
Join Date: Jul 2010
Posts: 49
woops, I meant to.

1984 300sd.

thanks.
Reply With Quote
  #4  
Old 05-08-2011, 11:10 AM
Unofficial wormcan opener
 
Join Date: Dec 2005
Location: Ashland, MA
Posts: 2,602
I would try a new 80 amp strip fuse. They are known to crack and cause intermittent starting problems.
__________________
1987 300TD 309, xxx 2.8.2014 10,000 mile OCI


Be careful of the toes you step on today, as they may be connected to the ass you have to kiss tomorrow. anonymous

“Be who you are and say what you feel, because those who mind don’t matter, and those who matter won’t mind.” Dr. Seuss
Reply With Quote
  #5  
Old 05-08-2011, 04:15 PM
Registered User
 
Join Date: Jul 2010
Posts: 49
i already multi-metered both sides and there is power. i also swapped the glow plug relay out for a known working unit. i am going to check the ground today.
Reply With Quote
  #6  
Old 05-08-2011, 04:47 PM
Unofficial wormcan opener
 
Join Date: Dec 2005
Location: Ashland, MA
Posts: 2,602
Quote:
Originally Posted by redline808 View Post
i already multi-metered both sides and there is power. i also swapped the glow plug relay out for a known working unit. i am going to check the ground today.
I understand that, but those fuses develop hair line cracks. They can test OK, but not allow enough power through for the car to start. If you do a search you can find several instances of this occurring. I keep a new one taped inside my glovebox for the next time mine cracks.

http://www.peachparts.com/search.htm?cx=015238323195528004774%3A_wneywo5nvm&cof=FORID%3A9&q=80+amp+fuse+crack&sa=Search&siteurl=www.peachparts.com%252Fshopforum%252Findex.php
__________________
1987 300TD 309, xxx 2.8.2014 10,000 mile OCI


Be careful of the toes you step on today, as they may be connected to the ass you have to kiss tomorrow. anonymous

“Be who you are and say what you feel, because those who mind don’t matter, and those who matter won’t mind.” Dr. Seuss
Reply With Quote
  #7  
Old 05-08-2011, 09:44 PM
Registered User
 
Join Date: Sep 2006
Location: Middle TN
Posts: 3,829
http://dieselgiant.com/glowplugrepair.htm

What part of this isn't working?
__________________
85SD 240K & stopped counting getting paint. 84SD 180,000. Probably up for sale in the fall 2020. 85TD beginning to repair to DD status.
Reply With Quote
  #8  
Old 05-09-2011, 03:54 AM
Registered User
 
Join Date: Jul 2010
Posts: 49
Quote:
Originally Posted by Junkman View Post
http://dieselgiant.com/glowplugrepair.htm

What part of this isn't working?
the relay was not activating, all glow plugs tested good.

i added my own ground and it still didnt work? so i swapped it out for another one. and now i was only getting 10v coming out of it. but at least it was turning on. what i did was open the case and i noticed that there was some corrosion around point connections, so i filed them clean, now i get 12v out. glow plug light comes on and car fires right up.

thanks.

Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On




All times are GMT -4. The time now is 12:00 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2020, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2018 Pelican Parts, LLC - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page