Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help




Go Back   PeachParts Mercedes-Benz Forum > Mercedes-Benz Tech Information and Support > Diesel Discussion

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 06-25-2011, 09:03 PM
Registered User
 
Join Date: Mar 2010
Location: Chicago Il
Posts: 44
Brake problems, pedal goes to the floor

i have an 87 300d , my rears brakes failed last week when they got hot and one tire was in fire, i managed to change calipers, hoses, pads and rotors but now when i put them all together and have the lines flushes and bleeds, the rears tires got again hot,
Then I replaced the master cylinder with a used one from a junkyard and now i have spongy pedal after firestone perform me a new bleeding and flushing for the brakes.
You might think that could be some air in the master or this replacement master is shot too?
I'm feeling desperate now and any help will be more than welcome
Reply With Quote
  #2  
Old 06-25-2011, 09:15 PM
Registered User
 
Join Date: Jan 2002
Posts: 18,355
If your pedal goes to the floor you either have a hole in a line or caliper or a bad MC.
How did a tire catch on fire?
__________________
1977 300d 70k--sold 08
1985 300TD 185k+
1984 307d 126k--sold 8/03
1985 409d 65k--sold 06
1984 300SD 315k--daughter's car
1979 300SD 122k--sold 2/11
1999 Fuso FG Expedition Camper
1993 GMC Sierra 6.5 TD 4x4
1982 Bluebird Wanderlodge CAT 3208--Sold 2/13
Reply With Quote
  #3  
Old 06-25-2011, 09:24 PM
Registered User
 
Join Date: Dec 2005
Location: Carson City, NV
Posts: 3,768
I wouldn't trust a junkyard master cylinder. My guess is it's probably bad. Could you tell us some more about the rears getting hot?
__________________
Anyone who thinks a 300D is fast drives too slow.

83 300D Turbo with manual conversion, early W126 vented front rotors and H4 headlights 357,xxx miles
08 Triumph Street Triple 24,xxx miles, lowered 10mm in front, Pirelli Angel GT tires, EBC HH brake pads, otherwise stock.
Reply With Quote
  #4  
Old 06-25-2011, 09:33 PM
Registered User
 
Join Date: Mar 2010
Location: Chicago Il
Posts: 44
the brakes was stuck, the calipers and pads getting hot melted the rubber in the caliper and then the brake fluid was in fire,
i was able to see a hose in some driveway and managed to stop the fire,
Reply With Quote
  #5  
Old 06-25-2011, 09:35 PM
Registered User
 
Join Date: Mar 2010
Location: Chicago Il
Posts: 44
i don't see to lose fluid, and with the first master cylinder the brake pedal was hard but the rear brakes was so hot....
how can i test a master cylinder then?
Reply With Quote
  #6  
Old 06-25-2011, 09:41 PM
Registered User
 
Join Date: Dec 2005
Location: Carson City, NV
Posts: 3,768
The original problem was most likely caused by either bad calipers or bad hoses. Since you've replaced those, you shouldn't be having that problem anymore. Did you use all new parts aside from the master cylinder?

Diagnosing a bad master cylinder is a process of elimination. If your pedal is going to the floor and you aren't losing fluid, you either still have air in the system or the internal piston seals in the master cylinder are bad. I would bleed the brakes again. It's possible Firestone may have done it wrong. If you still get the pedal going to the floor, the next step would be to replace the master cylinder.
__________________
Anyone who thinks a 300D is fast drives too slow.

83 300D Turbo with manual conversion, early W126 vented front rotors and H4 headlights 357,xxx miles
08 Triumph Street Triple 24,xxx miles, lowered 10mm in front, Pirelli Angel GT tires, EBC HH brake pads, otherwise stock.
Reply With Quote
  #7  
Old 06-25-2011, 09:51 PM
Registered User
 
Join Date: Mar 2010
Location: Chicago Il
Posts: 44
Quote:
Originally Posted by Skippy View Post
The original problem was most likely caused by either bad calipers or bad hoses. Since you've replaced those, you shouldn't be having that problem anymore. Did you use all new parts aside from the master cylinder?

Diagnosing a bad master cylinder is a process of elimination. If your pedal is going to the floor and you aren't losing fluid, you either still have air in the system or the internal piston seals in the master cylinder are bad. I would bleed the brakes again. It's possible Firestone may have done it wrong. If you still get the pedal going to the floor, the next step would be to replace the master cylinder.
the calipers was used but i rebuild them with the kit, the hoses was coming with the calipers (used), but same thing happened again, wheels was very hot.
Should i perform a bleeding process to the master?

can be some air trapped in the master?
Reply With Quote
  #8  
Old 06-25-2011, 09:57 PM
Registered User
 
Join Date: Mar 2010
Location: Chicago Il
Posts: 44
Quote:
Originally Posted by Skippy View Post
The original problem was most likely caused by either bad calipers or bad hoses. Since you've replaced those, you shouldn't be having that problem anymore. Did you use all new parts aside from the master cylinder?

Diagnosing a bad master cylinder is a process of elimination. If your pedal is going to the floor and you aren't losing fluid, you either still have air in the system or the internal piston seals in the master cylinder are bad. I would bleed the brakes again. It's possible Firestone may have done it wrong. If you still get the pedal going to the floor, the next step would be to replace the master cylinder.
i think the original problem was with a seal on the piston inside the MC, next think i will replace the hoses ... but takes time to order them!
Reply With Quote
  #9  
Old 06-25-2011, 10:08 PM
Registered User
 
Join Date: Jan 2002
Posts: 18,355
Not a good idea to put on used hoses in circumstance like that. Bad hoses can cause that kind of problem.
__________________
1977 300d 70k--sold 08
1985 300TD 185k+
1984 307d 126k--sold 8/03
1985 409d 65k--sold 06
1984 300SD 315k--daughter's car
1979 300SD 122k--sold 2/11
1999 Fuso FG Expedition Camper
1993 GMC Sierra 6.5 TD 4x4
1982 Bluebird Wanderlodge CAT 3208--Sold 2/13
Reply With Quote
  #10  
Old 06-25-2011, 10:25 PM
Registered User
 
Join Date: Sep 2001
Location: central Texas
Posts: 17,277
Why do you not take it back to Firestone and ask them why it still did that after they bled it.
They should put into writing why it was not fixed.
Then you have something to start with.
Reply With Quote
  #11  
Old 06-25-2011, 10:34 PM
Registered User
 
Join Date: Mar 2010
Location: Chicago Il
Posts: 44
they replaced only the fluid but the pedal is the same, and they don't know what is the cause without investigate it, i believe they just replaced the fluid in the master and they just bleed the brakes,
i explained them before how was my pedal and they was agree whit me that is some air trapped in the lines.
I refused to let the car there because at that point i was not confident about their work, they keep pointing me that i signed a contract and they did what i asked.

i will replace the hoses to new ones, but still i don't think the hoses was causing the blocking on the rear wheels. If they are failing they fail gradually and it was a coincidence to have them failing on both sides?
Reply With Quote
  #12  
Old 06-26-2011, 01:17 AM
A work in process...
 
Join Date: Oct 2009
Location: Texas
Posts: 985
Ok, I'm confused. You say the pedal goes to the floor yet the back wheel is still getting hot.

This tells me that the back pads are tight against the rotor and it's heating up due to friction. Furthermore, this tells me that the pistons in the calipers are not releasing. Leading me to believe that the caliper rebuild was not successful. Maybe there is a ridge that was not honed and it's catching the piston. This would cause the rear brakes to catch would it not?

All this barring bad wheel bearings or joints on axle assemblies.
__________________
Codifex
1981 240D ChinaBlue (Got her running with a donor engine.)
1983 300DTurbo w/sunroof.
1984 300TD manual sunroof. (Electrical Gremlins)

Last edited by Codifex Maximus; 06-26-2011 at 01:19 AM. Reason: All this barring bad wheel bearings or joints on axle assemblies.
Reply With Quote
  #13  
Old 06-26-2011, 09:21 AM
Registered User
 
Join Date: Mar 2010
Location: Chicago Il
Posts: 44
[QUOTE=Codifex Maximus;2741737]Ok, I'm confused. You say the pedal goes to the floor yet the back wheel is still getting hot.

This tells me that the back pads are tight against the rotor and it's heating up due to friction. Furthermore, this tells me that the pistons in the calipers are not releasing. Leading me to believe that the caliper rebuild was not successful. Maybe there is a ridge that was not honed and it's catching the piston. This would cause the rear brakes to catch would it not?

All this barring bad wheel bearings or joints on axle assemblies.[/QUOwith

with the original MC the rear brake was hot, the calipers are ok, they are going back to normal when i'm releasing the pressure from the line (it was a lot of pressure on the line without pushing the pedal).
At that point i suspect that is something wrong with the MC, so i grabed another one from a junkyard and with the second MC my pedal is going to the floor.
next i will try to replace the rubber between the reservoir and the MC and the rubber caps.
I don't know if it makes sense but i will give it a try.
Reply With Quote
  #14  
Old 06-26-2011, 09:35 AM
Registered User
 
Join Date: Jan 2002
Posts: 18,355
Quote:
Originally Posted by adysor View Post

they are going back to normal when i'm releasing the pressure from the line (it was a lot of pressure on the line without pushing the pedal).
.
Where are you releasing pressure on the line? At the caliper or at the master cylinder?
__________________
1977 300d 70k--sold 08
1985 300TD 185k+
1984 307d 126k--sold 8/03
1985 409d 65k--sold 06
1984 300SD 315k--daughter's car
1979 300SD 122k--sold 2/11
1999 Fuso FG Expedition Camper
1993 GMC Sierra 6.5 TD 4x4
1982 Bluebird Wanderlodge CAT 3208--Sold 2/13
Reply With Quote
  #15  
Old 06-26-2011, 01:21 PM
Moderator
 
Join Date: Jul 2001
Location: Old Lyme, Connecticut
Posts: 3,596
First, it is not unusual for a service shop that is not very familiar with MBs to have difficulty refilling the brake reservoir correctly. Old cars can have discolored plastic reservoirs that make seeing the rear section is full very difficult, as when it is empty there is no fill "line" to detect and an inexperienced mechanic may conclude the rear section is full when it is empty. Part of the problem can come if the shop is full and they do this in the lot where the car might not be on level ground. Nose down at any significant angle and filling the rear section (normally done by overfilling the front section) and this becomes near impossible.

As to your state of repair, I recommend you purchase only new or rebuilt by a professional service brake calipers, new hoses and start over. While you are at it, jack up the rear of the car, and try rotating the wheels by hand. IF the service brake is dragging, open the bleed screw and see if that changes anything. If you are lighting fires due to braking friction you should have very apparent drag. If opening the bleed screw does nothing, take the caliper on the side or sides that drag off and see if the problem goes away. I have had a buddy drive with the emergency brake on because the warning light went out on the dash, and cause the wheel bearings to fry (no fires though), then seize at highway speeds and spin in the bearing housing. Big bummer.

But you need to identify what is dragging. The service brake, the parking brake, or the wheel bearings. Or is the problem something else? Like fuel dripping on the brakes? The driver's side has a breather line, the main fuel line and the return line tucked up in the wheel well, and they generally rot out by now.

Good luck,

Jim
__________________
Own:
1986 Euro 190E 2.3-16 (291,000 miles),
1998 E300D TurboDiesel, 231,000 miles -purchased with 45,000,
1988 300E 5-speed 252,000 miles,
1983 240D 4-speed, purchased w/136,000, now with 222,000 miles.
2009 ML320CDI Bluetec, 89,000 miles

Owned:
1971 220D (250,000 miles plus, sold to father-in-law),
1975 240D (245,000 miles - died of body rot),
1991 350SD (176,560 miles, weakest Benz I have owned),
1999 C230 Sport (45,400 miles),
1982 240D (321,000 miles, put to sleep)
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On




All times are GMT -4. The time now is 03:53 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2018, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2018 Pelican Parts, LLC - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page