Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help



Go Back   PeachParts Mercedes-Benz Forum > Mercedes-Benz Tech Information and Support > Diesel Discussion

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 08-24-2011, 08:11 AM
benedict's Avatar
Registered User
 
Join Date: Aug 2010
Location: Sydney
Posts: 404
Throttle sticky to return to idle OM606

Hi,

My throttle is sticky to return to idle when engine is cold. It will return so far to about 1200rmp but then slowly go down to normal idle.

I've checked the accelerator cable and that is clear and same for the bowden cable- issue seems further downstream.

Return spring is there and in place which is down by the IP. There is a rod linkage with ball joints either side going from the IP pump towards the firewall about 150mm long going to a valve/gate of some kind. Does anyone know what this valve/gate is?

I will have to take the manifold off in order investigate further.

Almost cost me the garage door this morning as it got stuck when I tapped the accelerator and I was busy finding a place to put my coffee - in my cupholderless car.
Thanks

__________________
1995 E300 Diesel
Reply With Quote
  #2  
Old 08-24-2011, 11:57 AM
Registered User
 
Join Date: Dec 2005
Posts: 2,411
Check the pedal to see if its clear of any carpet or other clutter ,test to see if it moves freely.
Reply With Quote
  #3  
Old 08-24-2011, 02:57 PM
Registered User
 
Join Date: Nov 2010
Location: TX
Posts: 3,962
the linkage you mention that goes from the pump to a gate near the firewall is the one thats gets sticky, remove and lube it, FSM says ATF, I put a dab of grease on it, and its working fine ever since.

btw that "gate" is the cruise control. and you can see it by removing the top cross over pipe and not the whole manifold.
__________________
2012 BMW X5 (Beef + Granite suspension model)

1995 E300D - The original humming machine (consumed by Flood 2017)
2000 E320 - The evolution (consumed by flood 2017)
Reply With Quote
  #4  
Old 08-25-2011, 08:26 AM
benedict's Avatar
Registered User
 
Join Date: Aug 2010
Location: Sydney
Posts: 404
Quote:
Originally Posted by Zulfiqar View Post
the linkage you mention that goes from the pump to a gate near the firewall is the one thats gets sticky, remove and lube it, FSM says ATF, I put a dab of grease on it, and its working fine ever since.

btw that "gate" is the cruise control. and you can see it by removing the top cross over pipe and not the whole manifold.
Zulfiqar: Thanks for the tip about the need to only remove the crossover pipe. Do you think I will be able to get to the joints and oil them up with just the crossover removed?
__________________
1995 E300 Diesel
Reply With Quote
  #5  
Old 08-25-2011, 02:06 PM
Registered User
 
Join Date: Nov 2010
Location: TX
Posts: 3,962
yes

__________________
2012 BMW X5 (Beef + Granite suspension model)

1995 E300D - The original humming machine (consumed by Flood 2017)
2000 E320 - The evolution (consumed by flood 2017)
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On




All times are GMT -4. The time now is 06:43 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2023, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2018 Pelican Parts, LLC - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page