Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help




Go Back   PeachParts Mercedes-Benz Forum > Mercedes-Benz Tech Information and Support > Diesel Discussion

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 10-11-2011, 09:03 PM
Registered User
 
Join Date: Jun 2006
Location: Northern New Jersey
Posts: 167
Wipers (were) constantly on, now no starter!

Well, I think for sure I've needed a glow relay - it's been kinda iffy for a few months. OK, fair enough.

Then, recently, the ignition circuit turn on the windshield wipers - couldn't turn 'em off! - and now have no response from the starter, either...

Hmmm... What relay - or combination of things - could be causing this? Where does one start?
__________________
'83 300 SD
'68 Triumph TR 250 - The only car I ever loved more than the Mercedes; who needs electricity, anyway? - Damn, why did I sell it?!
'59 Jaguar 3.4 'Le Chat Noir' - Damn, why did I sell it?!

It's difficult to make predictions, especially about the future.
- Niels Bohr
Reply With Quote
  #2  
Old 10-11-2011, 09:32 PM
Biodiesel300TD's Avatar
|3iodiesel300T|)
 
Join Date: Dec 2004
Location: Albany, OR
Posts: 4,845
Are you working on the 83 SD in your profile?

I've had problems with the wipers doing crazy things because of moisture that had gotten into selector on the end of the wiper stalk. The end cap pops off then you can take it all apart. Give it clean, and see if that helps.

It sounds like maybe your neutral safety switch has gone bad. Try Shifting through the gears a couple times and try starting it again. Or try putting it in Neutral to start instead of Park and see if that changes anything.
__________________
Andrew
'04 Jetta TDI Wagon
'82 300TD ~ Winnie ~ Sold
'77 300D ~ Sold
Reply With Quote
  #3  
Old 10-11-2011, 10:16 PM
Registered User
 
Join Date: Sep 2006
Location: Middle TN
Posts: 3,476
I'd start by checking fuses with a meter and cleaning fuse contacts. You could have one or more problems with the switches - key switch & combo switch. Also, for the starter normal battery/connections clean/testing requirements apply.
__________________
85SD 240K & stopped counting. 84SD 180,000. Thinking of painting both.
Reply With Quote
  #4  
Old 10-19-2011, 11:19 AM
Registered User
 
Join Date: Jun 2006
Location: Northern New Jersey
Posts: 167
Gents - Thanks for your comments. Yes, the car has been leaking some rainwater, so this is intriguing - I thought I'd read someone else was having a wiper freakout because of a bad relay? I'm suspicious, because something had also been draining the battery.

OK, will keep you posted. I'll start working on this when I get back to The States.
__________________
'83 300 SD
'68 Triumph TR 250 - The only car I ever loved more than the Mercedes; who needs electricity, anyway? - Damn, why did I sell it?!
'59 Jaguar 3.4 'Le Chat Noir' - Damn, why did I sell it?!

It's difficult to make predictions, especially about the future.
- Niels Bohr
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On




All times are GMT -4. The time now is 02:59 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2018, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2018 Pelican Parts, LLC - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page