Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help




Go Back   PeachParts Mercedes-Benz Forum > Mercedes-Benz Tech Information and Support > Diesel Discussion

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 10-26-2011, 02:48 PM
Registered User
 
Join Date: Jan 2011
Location: South East Virginia
Posts: 31
troubleshooting rear window '80 300cd

problem... inoperative driver's side rear power window.

effort to repair: pulled panel, track and motor...
- tested motor - it works
- replaced everything and no luck getting the window to operate.
- no power to rear switch - haven't checked driver's switch.
- checked and replaced fuses, still no power to rear switch
if i find there is no power at driver's switch and fuses check... where should I check next? oh! both passenger window have power.

note: almost ready for state inspection, window, headlight adjustment and front end alignment are the remaining fixes and i'm on the road.

thx... seadog
Reply With Quote
  #2  
Old 10-26-2011, 03:08 PM
79Mercy's Avatar
Registered User
 
Join Date: Mar 2008
Location: Florida
Posts: 4,128
Child locks on?
__________________
1985 300TD Turbo Euro-wagon
1979 280CE 225,200 miles
1985 300D Turbo 264,000 miles
1976 240D 190,000 miles
1979 300TD 220,000

GONE but not forgotten
1976 300D 195,300 miles
1983 300D Turbo 175,000 miles

http://i42.photobucket.com/albums/e3...e485-1-2-1.jpg
Reply With Quote
  #3  
Old 10-26-2011, 07:12 PM
Registered User
 
Join Date: Jan 2011
Location: South East Virginia
Posts: 31
safety lock checks out... no problem here. after repeated/continous checking of all window switches and getting movement in all windows except rear left... passenger front stopped working. got frastrated and walked away for a few hours... returned and found that the right front - left rear 25A fuse had blown. replaced it and only the right front window operation was restored - still no action left rear. is this going to be a volt meter power check at the switch(s)? is there anywhere else to check?

thx.
Reply With Quote
  #4  
Old 10-26-2011, 07:35 PM
Registered User
 
Join Date: Mar 2008
Location: CT
Posts: 214
Try re arranging the switches in the console and rear seats from side to side to see if the problem follows the switch.
__________________
95 E300D working out the kinks
77 300D, 227k, station car
83 300CD 370k, gone away
89 190E 2.6- 335k, no more
79 VW FI Bus- 145k miles, summer driver
59 VW Beetle ragtop- 175k miles
12 VW Jetta- 160k miles
Reply With Quote
  #5  
Old 10-26-2011, 09:00 PM
Yak Yak is offline
Registered User
 
Join Date: Aug 2009
Location: San Antonio, TX
Posts: 1,711
It sounds like you've eliminated all the variables except the switches. Power goes through the console switch to the rear switch.

I'd look at the console switch first. Check connections, check for clean contacts. Swapping the console switch from right rear to left rear may be the easiest troubleshooting step. You may just be able to swap the connectors under the switch.
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On




All times are GMT -4. The time now is 12:31 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2018 Pelican Parts, LLC - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page