Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help




Go Back   PeachParts Mercedes-Benz Forum > Mercedes-Benz Tech Information and Support > Diesel Discussion

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 02-02-2012, 01:52 PM
Registered User
 
Join Date: Feb 2012
Posts: 1
300D Transmission gone? Or something else?

I have an 83 Mercedes 300D with a veggie conversion. I purchased the car and it drove fine for a few weeks. Without warning signs, after sitting a few days, the car would not go in reverse. The transmission fluid was overfull when I checked under the hood. The car started fine and went forward fine...just not backwards. Does this sounds like the transmission went, or something else?
Reply With Quote
  #2  
Old 02-02-2012, 02:36 PM
mespe's Avatar
benzbonz
 
Join Date: Feb 2005
Location: Cleveland, Ohio
Posts: 1,835
When you had reverse, did it take a few seconds to go into reverse? Drop the pan and see if there are any metal chunks and how much clutch grit is in there. Drain the torque converter too, and replace the filter and new fluid. Spending money on a flush is better than replacing a transmission that still might be good.
__________________
With thousands of Pre-Owned Mercedes parts ready to ship, we are now "mobile friendly" check out
Benzbonz.biz
on your smart phone or tablet.
Reply With Quote
  #3  
Old 02-02-2012, 02:48 PM
Registered User
 
Join Date: Jan 2002
Posts: 18,355
There's a reverse band adjustment on some of these trannies. don't know if yours has one.
__________________
1977 300d 70k--sold 08
1985 300TD 185k+
1984 307d 126k--sold 8/03
1985 409d 65k--sold 06
1984 300SD 315k--daughter's car
1979 300SD 122k--sold 2/11
1999 Fuso FG Expedition Camper
1993 GMC Sierra 6.5 TD 4x4
1982 Bluebird Wanderlodge CAT 3208--Sold 2/13
Reply With Quote
  #4  
Old 02-03-2012, 02:38 PM
Registered User
 
Join Date: Jan 2012
Location: Leiden, Netherlands
Posts: 611
Can you put it in R if the engine is off?
Reply With Quote
  #5  
Old 02-03-2012, 02:59 PM
Biodiesel300TD's Avatar
|3iodiesel300T|)
 
Join Date: Dec 2004
Location: Albany, OR
Posts: 4,845
Check the bushings on the shift linkage under the car. If one or both of them are worn or gone you can have shifting problems.
__________________
Andrew
'04 Jetta TDI Wagon
'82 300TD ~ Winnie ~ Sold
'77 300D ~ Sold
Reply With Quote
  #6  
Old 02-03-2012, 06:12 PM
Admiral-Third World Fleet
 
Join Date: Feb 2002
Location: Central FL
Posts: 3,068
Quote:
Originally Posted by kerry View Post
There's a reverse band adjustment on some of these trannies. don't know if yours has one.
Not that one.
__________________
80 300SD (129k mi) 82 240D stick (193k mi)77 240D auto - stick to be (153k mi) 85 380SL (145k mi) 89 BMW 535i 82 Diesel Rabbit Pickup (374k mi) 91 Jetta IDI Diesel (155k mi) 81 VW Rabbit Convertible Diesel 70 Triumph Spitfire Mk III (63kmi)66 Triumph TR4a IRS (90k mi)67 Ford F-100 (??)
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On




All times are GMT -4. The time now is 02:43 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2018 Pelican Parts, LLC - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page