Parts Catalog Accessories Catalog Tech Info Tech Forums
 
  Search our site:    
 Cart  | Project List | Order Status | Help    


Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Diesel Discussion

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 06-14-2012, 11:02 PM
Graham's Avatar
Registered User
 
Join Date: Nov 2004
Location: Ontario, Canada
Posts: 2,039
W123 Motor mounts

In repairing leak on primer pump of our 85 300D, I noticed that the motor mounts below looks split. Picture below.

Does the mount look like it should be replaced?

I never checked other side, but presumably both sides should be done at same time. And maybe tranny mount too?

Might have local garage do it - any idea of shop hours required?
Attached Thumbnails
W123 Motor mounts-img_1637.jpg  
__________________
Graham
85 300D
Reply With Quote
  #2  
Old 06-15-2012, 07:31 PM
Registered User
 
Join Date: Jul 2003
Location: Ocean Isle Beach, NC
Posts: 2,244
Just did mine for the same reason Graham.

See Motor mount - DIY for 240D
__________________
Len
'59 220S Cabriolet
'83 240D 350,000 miles original owner
'88 560SL 41,000 miles - being parted out
https://sites.google.com/site/mercedesstuff/home
'99 E300 turbo 181,500 miles
'03 SLK320 29,000 miles
Reply With Quote
  #3  
Old 06-15-2012, 07:38 PM
sassparilla_kid's Avatar
Registered User
 
Join Date: May 2012
Location: Fresno, CA
Posts: 233
Yeah that mount needs to be replaced, the driver's side mount always goes bad and gets spongy from having oil and diesel and stuff drip on it over time and they disintegrate. Mine came out in about 4 pieces.
__________________
1982 300D Turbodiesel, daily driver. Mods so far: Fram 8038 paper filter, 4 brake light mod, Gen II w126 (front) rotors/calipers, boost turned up to 12lbs, non-egr manifolds, water/methanol injection, 4-speed manual
1980 300SD Turbodiesel, project car, nearly ready to hit the street

1974 240D, New paint
Reply With Quote
  #4  
Old 06-15-2012, 08:51 PM
Graham's Avatar
Registered User
 
Join Date: Nov 2004
Location: Ontario, Canada
Posts: 2,039
Quote:
Originally Posted by sokoloff View Post
Just did mine for the same reason Graham.

See Motor mount - DIY for 240D
Thanks Len & s-k. Looks like I have another job on the never ending list! I may get local garage to put them in - Drivers side looks easy enough on 300D, but I could not even see the passenger side. But then I didn't try too hard!

Fortunately the E-class is now in good shape. Probably park it for most of summer ready for next year's trip South.

Next job on 300D is to paint wheel well edges with POR-15 to keep the rusties at bay.
__________________
Graham
85 300D
Reply With Quote
Reply

Bookmarks


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -4. The time now is 11:25 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page