Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help




Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Diesel Discussion

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 08-01-2012, 11:19 PM
Registered User
 
Join Date: Jul 2012
Posts: 48
little knockin when first started

Hi. I have a 1983 300d turbo and when i first start it up there is a knocking or ticking noise but once the engine is to op temp you dont hear it but you hear the natural om617 ticking sound? any idea what it is or whats causeing it?
Reply With Quote
  #2  
Old 08-01-2012, 11:24 PM
fashion victim immunizer
 
Join Date: Feb 2012
Location: oakland
Posts: 927
easiest answer is probably nailing injectors. search this forum for some information on that and how to take care of it!
__________________
1981 NA 300D 310k miles
Reply With Quote
  #3  
Old 08-01-2012, 11:30 PM
Registered User
 
Join Date: Jul 2012
Posts: 48
well they are new rebuilt injectors i got from performance products last year
__________________
what a day
Reply With Quote
  #4  
Old 08-02-2012, 12:39 AM
Diesel911's Avatar
Registered User
 
Join Date: Sep 2007
Location: Long Beach,CA
Posts: 21,962
Quote:
Originally Posted by Benz Kid View Post
well they are new rebuilt injectors i got from performance products last year
Check your Glow Plugs.

Could be you have a small Air Leak; once the Air is purged out it might run OK.

If your Compression is low it will do the same. A need for a Valve Adjustment can cause a slight compression issue.

Fuel Injection Pump Timing.

Late Valve Timing due to Timing Chain/Gear stretch or wear.

The Injectors you are speaking of haver Bosch Nozzles in them that have the central dilled Pintle with a tiny Hole and a larger cross drilled Hole. It could be that those holes are starting to fill with some Carbon.
It may be that a Diesel Purge would clean them out.

Not said: How many miles are on the Engine?
How Many Miles are on the Rebuilt Injectors?
What type of Fuel are you using?
Do you still have the Old Style Hand Primer with the shiny Aluminum Body on it?
When was the last Valve Adjustment.
A while back Hunter had commented on that there was some Bad Diesel Fuel going around. Are these symptoms happening on the same Tank Full of Fuel?
__________________
84 300D, 82 Volvo 244Gl Diesel
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On




All times are GMT -4. The time now is 02:49 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page