Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help




Go Back   PeachParts Mercedes-Benz Forum > Mercedes-Benz Tech Information and Support > Diesel Discussion

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 08-27-2012, 12:33 AM
ngarover's Avatar
Registered User
 
Join Date: Oct 2010
Location: Northern Georgia
Posts: 1,838
85 300TD Euro... feels like its starving for fuel.

Ok, first off, I'm a gluten for punishment as you all know by now.

I sold my 82 300TD on Saturday. Had sellers remorse almost immediately, so took a little of the cash and bought an 85 300TD Euro. (an actual import not a grey) So, I'm driving it home (2 hours) and about 20 miles into the trip she suddenly starts to loose power. I pull over, it's idling fine... figure well, lets limp it to a station and see whats up, but as soon as I take off I'm able to do 55 again. MAkes it about 10 miles and same thing, and so on till I finally reach a gas station. I pop the hood, car is idling perfect. no smoke nothing. revs up fine, check air filter, looks new, clean. Zero blow by. 223k on the odometer.

One thing I don't ever feel or hear the turbo... going to check that. The clear filter is clear, fuel is perfect in color, spin on filter is new (has a receipt)... could it be a tank strainer plugging up? Something is starving the engine for fuel. (alda?)


IP is painted grey, like it's been off at some point and rebuilt. I'll have to go threw the 2 inch stack of paper work and receipts on the car to see what has all been done in the past.

What would you suggest would be a good starting point?

About the car...

Have not gotten to deep into the car yet as I just finally got home. It does have the 3rd row seating, (including all 3 headrests) leather not mb tex in a sand color, has manual sunroof, cruise works and stalk is in german. Has us headlights, but also has wipers for the headlights, PO said that the Euro headlights had been changed out buy the guy he bought it from... A big clock in place of a tach. (not working) Has been repainted, but a fairly poor job. Will need to be wet sanded etc.

SLS works, rust free. (even on the doors bottom) Even has the drivers rear red fog light. Has correct tag in door showing the original buyer who imported the car and, it has a drivers side air bag! After-marked blaupunkt cd player... looks expensive. works.

Pictures to come...
Reply With Quote
  #2  
Old 08-27-2012, 12:37 AM
ngarover's Avatar
Registered User
 
Join Date: Oct 2010
Location: Northern Georgia
Posts: 1,838
Pictures from PO.
Attached Thumbnails
85 300TD Euro... feels like its starving for fuel.-5g75ef5kd3i83m33nfc8n7be24979522b1d29.jpg   85 300TD Euro... feels like its starving for fuel.-5ge5kd5md3ke3jf3hdc8n9872935cf22212f6.jpg   85 300TD Euro... feels like its starving for fuel.-5i85gf5ec3e13n63l0c8n588af593dc9017c1.jpg   85 300TD Euro... feels like its starving for fuel.-5ia5lf5x33gb3m23j9c8n8563fc1967ad1d14.jpg   85 300TD Euro... feels like its starving for fuel.-5ke5u45m13e93m23n3c8n06a660e3aeb2109a.jpg  

Reply With Quote
  #3  
Old 08-27-2012, 12:38 AM
ngarover's Avatar
Registered User
 
Join Date: Oct 2010
Location: Northern Georgia
Posts: 1,838
few more (Rear belts are there, they where just tucked under the seat)
Attached Thumbnails
85 300TD Euro... feels like its starving for fuel.-5nc5kb5m83ma3lf3pcc8n953d033004571342.jpg   85 300TD Euro... feels like its starving for fuel.-5ne5ic5jb3md3n73hac8n1309c3a53be019e4.jpg   85 300TD Euro... feels like its starving for fuel.-5nf5ea5m33k43k53lac8n1567530385c61571.jpg  
Reply With Quote
  #4  
Old 08-27-2012, 01:51 AM
compress ignite's Avatar
Drone aspiring to Serfdom
 
Join Date: Feb 2004
Location: 32(degrees) North by 81(degrees) West
Posts: 5,554
This Baby has a Turbo?

YOU know the Drill...
Check ALL and ANY of possible Vacuum/Pressure "Outages"

"Junk in the intake from EGR"
"Junk in the Alda system from EGR"

STARTRON...STARTRON...STARTRON !!! IN the Tank PDQ !

The Intermittent Power loss is either "Junk" in the Fuel or an Air Source!
__________________
'84 300SD sold
124.128
Reply With Quote
  #5  
Old 08-27-2012, 10:06 AM
ngarover's Avatar
Registered User
 
Join Date: Oct 2010
Location: Northern Georgia
Posts: 1,838
Quote:
Originally Posted by compress ignite View Post
YOU know the Drill...
Check ALL and ANY of possible Vacuum/Pressure "Outages"

"Junk in the intake from EGR"
"Junk in the Alda system from EGR"

STARTRON...STARTRON...STARTRON !!! IN the Tank PDQ !

The Intermittent Power loss is either "Junk" in the Fuel or an Air Source!
That was my basic idea also. I have an extra IP sitting here from my other 85 that I know is good if there happens to be an issue, same with the turbo. I'll get some pictures of the engine later, there are a few differences that I'm not sure about. Like the running of the valve cover vent... it does not goto the air cleaner, but is plumped into the air intake before the turbo....
Reply With Quote
  #6  
Old 08-27-2012, 10:18 AM
Registered User
 
Join Date: Dec 2011
Location: OC Cali
Posts: 110
is it possible that your brakes are overheating and clamping shut? This happened to me 15 miles into a drive?? Did the wheels smell burnt?
__________________
1985 300d Turbo Diesel
Reply With Quote
  #7  
Old 08-27-2012, 10:47 AM
gsxr's Avatar
Unbanned...?
 
Join Date: Aug 2001
Location: USA
Posts: 7,996
Swap the fuel supply & return hoses, and make sure the tank is full. If the problem goes away, it's the strainer.

__________________
Dave M.
Boise, ID

1997 E420 - 155kmi (Bugeyes)
1994 E420 - 145kmi (Blondie)
1993 500E - 193kmi (Lollipop)
1992 400E - 189kmi (Stinky Dirty)
Check out my website photos, documents, and movies!
Reply With Quote
  #8  
Old 08-27-2012, 12:33 PM
ngarover's Avatar
Registered User
 
Join Date: Oct 2010
Location: Northern Georgia
Posts: 1,838
Pulled the tank strainer, it was clean.

Checked the bango bolt, it was a little dirty, cleaned it and the tube and put back on. One thing I noticed, the PO has bypassed the valve on the firewall and gone straight to the alda. Not sure what that would do. Hooked up a boost gauge, 0. turbo spins free and no play in it. replaced a few crappy vac lines I found rechecked and got boost of about 2 (sitting still just revving the engine)

The air cleaner is odd. someone has removed the catch can and welded the hole shut. The valve cover vent tube instead runs to the u shaped hose connecting the air cleaner and the turbo (actually looks factory) the vent tube tee's off to a connection at the bottom of the air cleaner and just vents into the open space inside the air cleaner housing. There is nothing going to the tube below the air cleaner that the catch can would have normally gone to. Almost tempted to just put the air cleaner from my 85 on and plum it the way I know.

IP has been replaced at some point. It's been painted with that high temp grey engine paint (including the alda) So I'm thinking it's a junk yard item that was cleaned and painted to look good. I have a good IP sitting here from the 85 I parted out.

Also tempted to just remove the Alda completely as I've had it cause a no/low power issue on one of the other cars.

The EGR has been capped.

Noticed that the car has no Kilma even though it's an 85. Euro had no kilam? Also, it has a tach amp, but no tach... Just a big clock. Speedo goes up to 120. (right now I would be happy with 65)

Needs to have the boots replaced on the rear axels someone had rubber bagged them then used zip ties to hold it all together. seems to work just fine, but needs to be fixed correctly.

Looks like the original leveling for the headlights is still there. Wonder why the guy switch out the euro headlights for the US version? Seems silly with the wipers...

Spent more time under the car. It's very clean. no rust. checked all the major points very closely. Even the battery tray is clean, so that's good news. There is one hole in the drivers seat, does make it easy to tell that it's leather and not mb tex, will have to look into getting that repaired.

Car even has the add on rock guard for the oil pan!

Here are some various pictures I just took. Will try and get some video of the car later.

What is the thing in picture #3?
Attached Thumbnails
85 300TD Euro... feels like its starving for fuel.-img_4490.jpg   85 300TD Euro... feels like its starving for fuel.-img_4491.jpg   85 300TD Euro... feels like its starving for fuel.-img_4492.jpg   85 300TD Euro... feels like its starving for fuel.-img_4494.jpg   85 300TD Euro... feels like its starving for fuel.-img_4493.jpg  

Reply With Quote
  #9  
Old 08-27-2012, 12:35 PM
ngarover's Avatar
Registered User
 
Join Date: Oct 2010
Location: Northern Georgia
Posts: 1,838
more
Attached Thumbnails
85 300TD Euro... feels like its starving for fuel.-img_4495.jpg   85 300TD Euro... feels like its starving for fuel.-img_4496.jpg   85 300TD Euro... feels like its starving for fuel.-img_4497.jpg   85 300TD Euro... feels like its starving for fuel.-img_4498.jpg   85 300TD Euro... feels like its starving for fuel.-img_4499.jpg  

Reply With Quote
  #10  
Old 08-27-2012, 12:36 PM
ngarover's Avatar
Registered User
 
Join Date: Oct 2010
Location: Northern Georgia
Posts: 1,838
more more

Like the matching black ash tray, have not seen that before.

Note the factory listing of what the climate control buttons are for...
Attached Thumbnails
85 300TD Euro... feels like its starving for fuel.-img_4500.jpg   85 300TD Euro... feels like its starving for fuel.-img_4501.jpg   85 300TD Euro... feels like its starving for fuel.-img_4502.jpg   85 300TD Euro... feels like its starving for fuel.-img_4503.jpg   85 300TD Euro... feels like its starving for fuel.-img_4504.jpg  

Reply With Quote
  #11  
Old 08-27-2012, 12:37 PM
ngarover's Avatar
Registered User
 
Join Date: Oct 2010
Location: Northern Georgia
Posts: 1,838
more more more

Even the first aid kit is in german...
Attached Thumbnails
85 300TD Euro... feels like its starving for fuel.-img_4505.jpg   85 300TD Euro... feels like its starving for fuel.-img_4506.jpg   85 300TD Euro... feels like its starving for fuel.-img_4507.jpg   85 300TD Euro... feels like its starving for fuel.-img_4508.jpg   85 300TD Euro... feels like its starving for fuel.-img_4509.jpg  

Reply With Quote
  #12  
Old 08-27-2012, 12:41 PM
gsxr's Avatar
Unbanned...?
 
Join Date: Aug 2001
Location: USA
Posts: 7,996
Remember that you cannot measure boost pressure in the driveway... it has to be measured under load while driving.

__________________
Dave M.
Boise, ID

1997 E420 - 155kmi (Bugeyes)
1994 E420 - 145kmi (Blondie)
1993 500E - 193kmi (Lollipop)
1992 400E - 189kmi (Stinky Dirty)
Check out my website photos, documents, and movies!
Reply With Quote
  #13  
Old 08-27-2012, 12:43 PM
Registered User
 
Join Date: Jan 2002
Posts: 18,355
That's a standard PCV hose set up for an early turbo engine in the 116. Are you sure the engine has not been swapped out? Would a Euro wagon have a turbo? Most didn't.
__________________
1977 300d 70k--sold 08
1985 300TD 185k+
1984 307d 126k--sold 8/03
1985 409d 65k--sold 06
1984 300SD 315k--daughter's car
1979 300SD 122k--sold 2/11
1999 Fuso FG Expedition Camper
1993 GMC Sierra 6.5 TD 4x4
1982 Bluebird Wanderlodge CAT 3208--Sold 2/13
Reply With Quote
  #14  
Old 08-27-2012, 01:37 PM
ngarover's Avatar
Registered User
 
Join Date: Oct 2010
Location: Northern Georgia
Posts: 1,838
Quote:
Originally Posted by kerry View Post
That's a standard PCV hose set up for an early turbo engine in the 116. Are you sure the engine has not been swapped out? Would a Euro wagon have a turbo? Most didn't.
Don't know yet. I have a pile of receipts to pour though to get an idea of what has been done on the car.
Reply With Quote
  #15  
Old 08-27-2012, 03:35 PM
Registered User
 
Join Date: Nov 2004
Location: Nova Scotia, Canada.
Posts: 6,510
I know the car is newer but could the tank vent be partially blocked? Try it with the fuel cap loosened off.
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On




All times are GMT -4. The time now is 08:05 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2018 Pelican Parts, LLC - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page