Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help




Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Diesel Discussion

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 09-11-2012, 12:54 PM
Orv's Avatar
Orv Orv is offline
Registered User
 
Join Date: Mar 2011
Posts: 698
'81 300TD odometer problem (NOT the gear)

The odometer on my '81 300TD wagon has started to advance only intermittently. The faster I go, the worse it gets; by 70 mph, it's reading less than half the actual mileage when compared to the freeway mileposts. Needless to say this makes my fuel economy numbers look pretty bad.

A complicating factor here is that the '81 TD odometer is, I think, unique; unlike other W123s, it's electronic, with no mechanical cable connection. This means I can't just go grab a speedometer head from another W123 at the junkyard.

Importantly, the speedometer needle indicates correctly at all speeds, according to my GPS, which I think rules out the sender. The problem must be inside the speedometer head.

What I've done so far:
I pulled the instrument cluster, took out the speedometer head, and checked the plastic gears -- they were all good, and the mechanism moved freely when I worked it by hand. I also resoldered all the connections that looked at all flaky. It didn't help and the problem seems to be getting worse over time.

Any ideas on where to go from here?
Reply With Quote
  #2  
Old 09-11-2012, 03:46 PM
vstech's Avatar
DD MOD, HVAC,MCP,Mac,GMAC
 
Join Date: Mar 2006
Location: Mount Holly, NC
Posts: 26,129
not the gear eh? are you ABSOLUTELY CERTAIN?
it uses the same internals as the 81-84 300SD, so you could pull one of those and swap components if you need one. you cannot swap the entire speedometer, as it will not fit.
__________________
John HAUL AWAY, OR CRUSHED CARS!!! HELP ME keep the cars out of the crusher! A/C Thread
"as I ride with my a/c on... I have fond memories of sweaty oily saturdays and spewing R12 into the air. THANKS for all you do!

My drivers:
1987 190D 2.5Turbo
1987 190D 2.5Turbo
1987 190D 2.5-5SPEED!!!

1987 300TD
1987 300TD
1994GMC 2500 6.5Turbo truck... I had to put the ladder somewhere!
Reply With Quote
  #3  
Old 09-11-2012, 05:45 PM
Orv's Avatar
Orv Orv is offline
Registered User
 
Join Date: Mar 2011
Posts: 698
Yeah, definitely not the gear. This is the third VDO speedo I've had apart, so I was as surprised as you are to find out the gears weren't broken.

Good to know about the SD speedo, thanks. That's the kind of info I needed to know. I suspect a bad cap or something in the internal electronics...something just far enough out of spec to cause it to miss pulses when the pulses get shorter at speed.
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On




All times are GMT -4. The time now is 04:34 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2018, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2018 Pelican Parts LLC - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page