Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help




Go Back   PeachParts Mercedes-Benz Forum > Mercedes-Benz Tech Information and Support > Diesel Discussion

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 02-25-2013, 02:27 PM
blackestate's Avatar
Registered User
 
Join Date: Aug 2005
Location: Washington State
Posts: 948
alternator only option?

Car came home with all kinds of electrical issues. Found the battery dead. So I charged it up, and everything is fine. With the car running, and the lights and heater on full, the Voltage at the battery drops.
Pretty sure it is the alt. and no fuses anywhere that I cam see, So before I pull it out, ask the experts.

Thanks
Doug
__________________
83 300SD Dark Silver Dark brown inside
Reply With Quote
  #2  
Old 02-25-2013, 02:38 PM
toomany MBZ's Avatar
Registered User
 
Join Date: Nov 2006
Location: central Va
Posts: 7,820
Does your red battery light glow?

Check in the dark.

If so, a new voltage regulator is in order.
__________________
83 SD

84 CD
Reply With Quote
  #3  
Old 02-25-2013, 02:39 PM
blackestate's Avatar
Registered User
 
Join Date: Aug 2005
Location: Washington State
Posts: 948
No, I have not checked it in the dark. Is the regulator part of the alternator on a 83 300SD?
__________________
83 300SD Dark Silver Dark brown inside
Reply With Quote
  #4  
Old 02-25-2013, 02:46 PM
vstech's Avatar
DD MOD, HVAC,MCP,Mac,GMAC
 
Join Date: Mar 2006
Location: Mount Holly, NC
Posts: 26,180
Battery drains are difficult to track, yes, the alternator is dead, but it could need a simple Voltage Regulator for around $40
GET a multimeter and take some battery readings with the car off, key on, car running, and report back with what you find.
__________________
John HAUL AWAY, OR CRUSHED CARS!!! HELP ME keep the cars out of the crusher! A/C Thread
"as I ride with my a/c on... I have fond memories of sweaty oily saturdays and spewing R12 into the air. THANKS for all you do!

My drivers:
1987 190D 2.5Turbo
1987 190D 2.5Turbo
1987 190D 2.5-5SPEED!!!

1987 300TD
1987 300TD
1994GMC 2500 6.5Turbo truck... I had to put the ladder somewhere!
Reply With Quote
  #5  
Old 02-25-2013, 02:50 PM
blackestate's Avatar
Registered User
 
Join Date: Aug 2005
Location: Washington State
Posts: 948
With the key off the battery builds voltage. The key on is the same as running for the most part, a slow drop, when the lights and heater is on, then the voltage drops more rapidly. With the car running should I be getting 14V from the alt? I just got it charged adn started looking at it.
__________________
83 300SD Dark Silver Dark brown inside
Reply With Quote
  #6  
Old 02-25-2013, 02:53 PM
vstech's Avatar
DD MOD, HVAC,MCP,Mac,GMAC
 
Join Date: Mar 2006
Location: Mount Holly, NC
Posts: 26,180
most stock MB alts put out around 13V at idle... if you get 14 you're the exception.
anything below 12.8 at idle, and the alt/regulator is suspect...

post the exact voltage in the three positions I listed in my first question please. diagnosis is easier with numbers to follow...
__________________
John HAUL AWAY, OR CRUSHED CARS!!! HELP ME keep the cars out of the crusher! A/C Thread
"as I ride with my a/c on... I have fond memories of sweaty oily saturdays and spewing R12 into the air. THANKS for all you do!

My drivers:
1987 190D 2.5Turbo
1987 190D 2.5Turbo
1987 190D 2.5-5SPEED!!!

1987 300TD
1987 300TD
1994GMC 2500 6.5Turbo truck... I had to put the ladder somewhere!
Reply With Quote
  #7  
Old 02-25-2013, 02:56 PM
blackestate's Avatar
Registered User
 
Join Date: Aug 2005
Location: Washington State
Posts: 948
at idle with the lights and heater on I was at 11.75, then after doing a few things, about 10 minutes, it was down to 11.5
__________________
83 300SD Dark Silver Dark brown inside
Reply With Quote
  #8  
Old 02-25-2013, 03:09 PM
vstech's Avatar
DD MOD, HVAC,MCP,Mac,GMAC
 
Join Date: Mar 2006
Location: Mount Holly, NC
Posts: 26,180
yup. sounds like bad regulator as a minimum...
__________________
John HAUL AWAY, OR CRUSHED CARS!!! HELP ME keep the cars out of the crusher! A/C Thread
"as I ride with my a/c on... I have fond memories of sweaty oily saturdays and spewing R12 into the air. THANKS for all you do!

My drivers:
1987 190D 2.5Turbo
1987 190D 2.5Turbo
1987 190D 2.5-5SPEED!!!

1987 300TD
1987 300TD
1994GMC 2500 6.5Turbo truck... I had to put the ladder somewhere!
Reply With Quote
  #9  
Old 02-25-2013, 03:18 PM
blackestate's Avatar
Registered User
 
Join Date: Aug 2005
Location: Washington State
Posts: 948
Thanks, I will get to work and get it changed and go from there.

Thanks again
__________________
83 300SD Dark Silver Dark brown inside
Reply With Quote
  #10  
Old 02-25-2013, 05:11 PM
Registered User
 
Join Date: Oct 2012
Posts: 4,402
It does not sound like the issue you have. Yet just in case the glow plugs are staying on just check for voltage being present at the plugs when it should not be. Only takes a few seconds.

The alternator cannot overcome their draw if constantly on and the voltage will sag. As stated I do not think it is your problem. Still should usually be checked as it takes so little to do.
Reply With Quote
  #11  
Old 02-25-2013, 05:52 PM
toomany MBZ's Avatar
Registered User
 
Join Date: Nov 2006
Location: central Va
Posts: 7,820
1985 Mercedes-Benz 300SD Sedan - Charging System & Battery - Page 1
__________________
83 SD

84 CD
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On




All times are GMT -4. The time now is 12:21 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2018, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2018 Pelican Parts, LLC - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page