Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help




Go Back   PeachParts Mercedes-Benz Forum > Mercedes-Benz Tech Information and Support > Diesel Discussion

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 04-23-2013, 07:52 PM
Registered User
 
Join Date: Aug 2012
Posts: 28
Neutral safety switch

Hi, on my '87 300TD got a problem that car would not start in Park, but it starts fine in Neutral; it is not always; usually first thing in the morning while it will be starting fine in Park after it was used that day...
I guess it would be safety switch issue, but would like to check if it might be something else or what is the right procedure to troubleshoot.

PS. Just replaced the bushings on the shifter rod, so it is nice and tight now, but this did not fix/help the problem.
Reply With Quote
  #2  
Old 04-23-2013, 09:21 PM
Control Freak
 
Join Date: Oct 2011
Location: Columbia, SC
Posts: 3,158
Be sure the shift linkage is adjusted properly. PO might have monkeyed with the adjustment nuts to compensate for bad shifter bushings.

On the 124 the transmission controls the detents (the operator's handle flops like a fish when disconnected from the transmission).

Since the operator lever pivots in the center, pushing the operators handle to P causes the selector lever on the transmission to go all the way rearward.

I would make sure the transmission end of the linkage is solidly in the P position with the rod disconnected then attempt to crank the car. If it cranks then your NSS is good and the linkage needs to be adjusted. I think you could be hitting the mechanical end of travel on the operator lever when going to P but the lever on the transmission isn't quite to the right place.

VStech and I went through this on mine, it is a 2 man job, one to be under the car adjusting the linkage and the other to move the lever through the various positions.
__________________
2014 ML350 Bluetec (wife's DD)
2008 E320 Bluetec (my DD)
2008 ML320 CDI (Older son's college DD)
1998 E300DT (Younger son's college DD)
1987 300TD sold to vstech
----------
gone but living on
1983 240D (body to greazzer, engine to t walgamuth)
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On




All times are GMT -4. The time now is 06:54 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2018, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2018 Pelican Parts, LLC - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page