Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help




Go Back   PeachParts Mercedes-Benz Forum > Mercedes-Benz Tech Information and Support > Diesel Discussion

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 06-26-2013, 10:39 AM
Registered User
 
Join Date: Oct 2006
Location: Southern NJ
Posts: 357
99 W210 Intermittent A/C Problem

When the A/C is operating I am getting a discharge temp of 48-51 Deg.

I can drive to lunch come out, restart and NO A/C. Just blows hot. I can stop somewhere again, restart and A/C operates fine.

Over the years I have had freon properly added, but I am wondering since I have never had it evacuated, could moisture have entered the system and it freezes at the expansion valve ??

What values/addresses should I look at if it is electrical ??

Any assistance is greatly appreicated !!
__________________
Gary
Experience is something you get, Just after you needed it....
'99 E300 295K, '83 300D 220K, '75 240D 185K sold
'80 MCI Bus Conv DD 6V92TA, w/4 cyl. Kubota diesel GenSet 12.5KW
Reply With Quote
  #2  
Old 06-26-2013, 12:16 PM
Registered User
 
Join Date: Feb 2004
Location: Walnut Creek, CA & 1,150 miles S of Key West
Posts: 4,874
Check your Douvalve. Lil twin silo's next to the computer box.

Solid smack with a rubber handled screwdriver helps sometimes.

Can be rebuilt also.
__________________
Terry Allison
N. Calif. & S. of Key West

09' E320 Bluetec 77k
Reply With Quote
  #3  
Old 06-26-2013, 12:22 PM
Registered User
 
Join Date: Oct 2006
Location: Southern NJ
Posts: 357
Will Do, next time it quits,

Anything else I should be looking for on the ECM display ?

Thanks

Sent PM
__________________
Gary
Experience is something you get, Just after you needed it....
'99 E300 295K, '83 300D 220K, '75 240D 185K sold
'80 MCI Bus Conv DD 6V92TA, w/4 cyl. Kubota diesel GenSet 12.5KW
Reply With Quote
  #4  
Old 06-26-2013, 09:36 PM
Registered User
 
Join Date: Oct 2006
Location: Southern NJ
Posts: 357
Did some research on Dou valve and I will look to pull them, clean & lube them.
Do they control the heat to each side of interior ?

If so what is the chances both would pass same time ?
__________________
Gary
Experience is something you get, Just after you needed it....
'99 E300 295K, '83 300D 220K, '75 240D 185K sold
'80 MCI Bus Conv DD 6V92TA, w/4 cyl. Kubota diesel GenSet 12.5KW
Reply With Quote
  #5  
Old 06-26-2013, 11:50 PM
KarTek's Avatar
<- Ryuko of Kill La Kill
 
Join Date: Jun 2007
Location: Bahama/Eno Twp, NC
Posts: 3,249
I think it's more likely the controller is having problems. The way the duo-valve works, when there's no power, the heat is full on. you can pull the connector and test for voltage that comes and goes. A steady low would seem to indicate a failure. A steady high is OK.
Reply With Quote
  #6  
Old 06-27-2013, 05:44 AM
Registered User
 
Join Date: Oct 2006
Location: Southern NJ
Posts: 357
KarTek,

Where should I start to determine if a controller problem ?

Thanks
__________________
Gary
Experience is something you get, Just after you needed it....
'99 E300 295K, '83 300D 220K, '75 240D 185K sold
'80 MCI Bus Conv DD 6V92TA, w/4 cyl. Kubota diesel GenSet 12.5KW
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On




All times are GMT -4. The time now is 04:55 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2018, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2018 Pelican Parts, LLC - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page