Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help



Go Back   PeachParts Mercedes-Benz Forum > Mercedes-Benz Tech Information and Support > Diesel Discussion

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 09-11-2013, 06:26 AM
300SDLandRover's Avatar
Registered User
 
Join Date: Jul 2013
Posts: 75
vickers p.s. pump loose. need help!

Like the title says. my whole pulley and hub, (guess u would call it) are loose. there is a center hole empty. is it just bolted on? If so what size, thread, and length bolt is it if anyone would be a gent and remove theirs? If thats not the case, is it a retaining pin or something internal? This is an OM603 by the way. thank you for any help in advance

__________________
Lotus 7 replica-20valve 4AGE
06' 500R Ninja Naked/Café/Custom
86' 300 SDL (Donor)
98' Discovery 50th anniversary (Recipient of transplant)
Reply With Quote
  #2  
Old 09-11-2013, 09:15 AM
pwogaman's Avatar
Senior Member
 
Join Date: May 2003
Location: Northern, Virginia
Posts: 2,029
Pictures please.
__________________
http://i284.photobucket.com/albums/l...aman/Fleet.jpg

Peach Parts W124.128 User Group.

80 280SL
85 300SD
87 300TD
90 300TE 4Matic
90 300D 2.5 Turbo
92 300D 2.5 Turbo
92 300TE 4Matic
01 Saab 9-5 Wagon
Reply With Quote
  #3  
Old 09-11-2013, 01:23 PM
300SDLandRover's Avatar
Registered User
 
Join Date: Jul 2013
Posts: 75
The hole that can barely be seen in between the three mounting bolts is the one in question
Attached Thumbnails
vickers p.s. pump loose. need help!-2013-09-11-10.19.42.jpg  
__________________
Lotus 7 replica-20valve 4AGE
06' 500R Ninja Naked/Café/Custom
86' 300 SDL (Donor)
98' Discovery 50th anniversary (Recipient of transplant)
Reply With Quote
  #4  
Old 09-11-2013, 01:35 PM
300SDLandRover's Avatar
Registered User
 
Join Date: Jul 2013
Posts: 75
Heres a video. couldnt figure out how to upload or embed.

300sdl/OM603 Vickers power steering pump loose - YouTube
__________________
Lotus 7 replica-20valve 4AGE
06' 500R Ninja Naked/Café/Custom
86' 300 SDL (Donor)
98' Discovery 50th anniversary (Recipient of transplant)
Reply With Quote
  #5  
Old 09-11-2013, 02:14 PM
Registered User
 
Join Date: Jul 2012
Posts: 81
Looks to me like a broken shaft inside the pump. My dad had that happen on an almost new Dodge Ram one time - shaft sheared off inside front bearing of the pump.

The hub that the 3 bolts holding the pulley on go into should be pressed (very tightly) on to the shaft. I really doubt the movement is there - I think the whole shaft is going in/out. Time for a new pump.
Reply With Quote
  #6  
Old 09-11-2013, 02:17 PM
Registered User
 
Join Date: Jul 2012
Posts: 81
BTW - Is there any power steering assist now? Did you notice the wheel get harder to turn specially when not moving?
Reply With Quote
  #7  
Old 09-11-2013, 02:19 PM
300SDLandRover's Avatar
Registered User
 
Join Date: Jul 2013
Posts: 75
NO power steering. pulley spins. not the "innerds"
__________________
Lotus 7 replica-20valve 4AGE
06' 500R Ninja Naked/Café/Custom
86' 300 SDL (Donor)
98' Discovery 50th anniversary (Recipient of transplant)
Reply With Quote
  #8  
Old 09-11-2013, 07:58 PM
Registered User
 
Join Date: Jan 2012
Posts: 7,515
This should be a vane type pump, if the shaft didn't shear, it lost the snap ring that holds the rotor to the shaft allowing the shaft to slide out of the pump body. Finding a proper snap ring might prove to be difficult making a used pump a better route.

The hole you see in the center of the shaft is where a threaded install tool attaches to force the pump hub onto the shaft.
Reply With Quote
  #9  
Old 09-11-2013, 08:23 PM
jay_bob's Avatar
Control Freak
 
Join Date: Oct 2011
Location: Columbia, SC
Posts: 3,638
I agree on the pump self destruction theory. Time to hit the yards.

Be aware that the 603 equipped wagons have a dual pump, one circuit for the power steering and the other for the SLS rear suspension, that will not work for you. I would look for a 300E or 300D sedan from 86 to 95 for the part.

When you get the replacement installed, leave the return line off the pump and point it into a container, and purge the system by pouring in new fluid while turning the wheel side to side, and then you should be good to go.
__________________
The OM 642/722.9 powered family
2014 ML350 Bluetec (wife's DD)
2013 E350 Bluetec (my DD)
2008 ML320 CDI (Older son’s DD)
2008 E320 Bluetec (Younger son's DD)

1998 E300DT sold to TimFreeh
1987 300TD sold to vstech
----------
gone but living on
1983 240D (body to greazzer, engine to t walgamuth)
Reply With Quote
  #10  
Old 09-12-2013, 03:34 PM
300SDLandRover's Avatar
Registered User
 
Join Date: Jul 2013
Posts: 75
Funny. i got a replacement for $20 off "my" parts car at my wrecking yard.(no one else has a car like mine here!). Yeah, i think the snap ring must have came off. i'll put on the replacement then tear into mine to verify. thanks for the advice guys
__________________
Lotus 7 replica-20valve 4AGE
06' 500R Ninja Naked/Café/Custom
86' 300 SDL (Donor)
98' Discovery 50th anniversary (Recipient of transplant)
Reply With Quote
  #11  
Old 09-12-2013, 10:17 PM
Registered User
 
Join Date: Jan 2012
Posts: 7,515
A few things, You might want to tell the salvage yard that you are buying parts from the car. They might keep it around if they know you are a regular customer or even offer a cut rate when it is due to go.

Lotus 7 rep , , , , cool.

06' 500R Ninja Naked/Café/Custom , , ,I hear this is the new thing, in the old days bikes had exposed engines and no plastic. . .
Reply With Quote
  #12  
Old 09-15-2013, 02:56 PM
300SDLandRover's Avatar
Registered User
 
Join Date: Jul 2013
Posts: 75
Quote:
Originally Posted by 97 SL320 View Post
A few things, You might want to tell the salvage yard that you are buying parts from the car. They might keep it around if they know you are a regular customer or even offer a cut rate when it is due to go.

Lotus 7 rep , , , , cool.

06' 500R Ninja Naked/Café/Custom , , ,I hear this is the new thing, in the old days bikes had exposed engines and no plastic. . .
Hey thanks. got the Lotus on a "5yr plan" (approx 40% done). Ninja 500/ex500/gpz500 (whatever you wanna call it) plastics havent changed since 80's, and IMHO are hideous. Mine, if i say so myself, looks the "dogs bollox"!
Attached Thumbnails
vickers p.s. pump loose. need help!-2013-09-15-11.54.02.jpg  

__________________
Lotus 7 replica-20valve 4AGE
06' 500R Ninja Naked/Café/Custom
86' 300 SDL (Donor)
98' Discovery 50th anniversary (Recipient of transplant)
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On




All times are GMT -4. The time now is 07:43 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2020, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2018 Pelican Parts, LLC - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page