Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help



Go Back   PeachParts Mercedes-Benz Forum > Mercedes-Benz Tech Information and Support > Diesel Discussion

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 09-11-2013, 04:57 PM
Registered User
 
Join Date: May 2013
Posts: 53
MB E270 CDI - strange "air leak" sound from exhaust/ inlet/ turbo area

The E270 CDI started to make a strange "air leak" sound when it's warm. When cold starting there is no special sound, but when the temperature increases there is a "air leak" sound. Not like typical exhaust leakage, but more quit and lighter sound.

When increasing the reps, the sound is louder.

The power is also a little down I think. Tried today to max the car when going onto the main road, and then the engine went into "safe mode". There was no sign on the dashboard display, but yet the car was certainly in safe mode.

What can cause this sound etc?

- air leakage in exhaust?
- broken turbo?
- other ideas?

Will try to get a Star read out tomorrow, but not sure if that will tell anything.

Very open for ideas and shared experience :-)

Reply With Quote
  #2  
Old 09-11-2013, 08:10 PM
Diesel911's Avatar
Registered User
 
Join Date: Sep 2007
Location: Long Beach,CA
Posts: 34,912
I don't know how this would work out on a hot engine as I advise people to do this cold.
Get one of those squeeze Bottles that you spray with and fill it with a mix of water and Dawn Dish Soap made in a bubble mix.
1 gallon of water to 1 Cup of Dawn. My Wife uses this to make bubble mix for Her Preschool Class. You can reduce the amounts as you like but keep the ratio of water to dawn.

You spray it on a cold Engine and start it and if there is an exhaust or Air Pressure external leak it will bubble.
I have never tried it on a hot Engine so I don't know the results there.

From your description it sound more like an intake leak.
__________________
84 300D, 82 Volvo 244Gl Diesel
Reply With Quote
  #3  
Old 09-12-2013, 03:27 AM
Registered User
 
Join Date: May 2013
Posts: 53
I got the results from the Star today. It is the turbo pressure indicator that is bad. Need to change that. Appr. $100 for the part I was told. That will fix the "safe mode" issue I think.

I also thought the sound was an intake leak, so it might be. The intake filter is in a plastic housing, so there might be a case where the intake filter housing etc start to leak when it get heated by the engine.

The bubble trick seams neat. I guess it will not work on a very hot surface, but who knows? Need to try :-)

Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On




All times are GMT -4. The time now is 05:15 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2020, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2018 Pelican Parts, LLC - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page