Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help




Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Diesel Discussion

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 10-03-2013, 09:39 AM
Registered User
 
Join Date: Apr 2008
Posts: 104
OVP FYI overvoltage relay

300SDL
I had an odd situation where my tach went dead at the same time as my "antilock" idiot light went on. Tach stayed dead and warning light stayed on after restarts. Reading some forum posts, it smelled like a bad OVP relay. So I swapped the OVP out with a good one I had lying around, and...FIXED. Every now and then there ARE easy successes.

Thanks to all the brave pioneers who skinned their knuckles before me.
Reply With Quote
  #2  
Old 10-03-2013, 10:26 AM
Registered User
 
Join Date: Sep 2013
Posts: 146
I had a similar issue on my 87. I replaced the fuse on the OVP and that resolved it. I did decide to replace the OVP as it was old.
Reply With Quote
  #3  
Old 10-07-2013, 02:03 PM
Registered User
 
Join Date: Apr 2008
Posts: 104
FUSE VS OVP

Yes, indeed, one must check the fuse first, rather than just junking the thing. I did, but I can't prove it.
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On




All times are GMT -4. The time now is 12:01 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page