Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help




Go Back   PeachParts Mercedes-Benz Forum > Mercedes-Benz Tech Information and Support > Diesel Discussion

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 11-28-2013, 12:38 AM
Zacharias's Avatar
Not so amused
 
Join Date: Apr 2010
Location: West Quebec
Posts: 4,025
Climate control no longer working in "econ" mode

Climate control is working great on my '85 300d, but only when the left three buttons are depressed. No blower action when 'econ' setting is pressed.

Is this a bad control (pushbutton) unit?
__________________


Mac
2002 e320 4matic estate│1985 300d│1980 300td
Previous: 1979 & 1982 & 1983 300sd │ 1982 240d

“Let's take a drive into the middle of nowhere with a packet of Marlboro lights and talk about our lives.” ― Joseph Heller, Catch-22
Reply With Quote
  #2  
Old 11-28-2013, 12:50 AM
Registered User
 
Join Date: Jan 2002
Posts: 18,354
On mine, econ won't work unless I push the defrost button first to get the blower turning. Not sure what's causing that but it's been that way for a couple of years. I've never bothered trying to diagnose it.
__________________
1977 300d 70k--sold 08
1985 300TD 185k+
1984 307d 126k--sold 8/03
1985 409d 65k--sold 06
1984 300SD 315k--daughter's car
1979 300SD 122k--sold 2/11
1999 Fuso FG Expedition Camper
1993 GMC Sierra 6.5 TD 4x4
1982 Bluebird Wanderlodge CAT 3208--Sold 2/13
Reply With Quote
  #3  
Old 11-28-2013, 10:32 AM
toomany MBZ's Avatar
Registered User
 
Join Date: Nov 2006
Location: central Va
Posts: 7,820
Entirely possible, a cold solder or two can have this effect.
__________________
83 SD

84 CD
Reply With Quote
  #4  
Old 11-28-2013, 02:17 PM
sixto's Avatar
smoke gets in your eyes
 
Join Date: Jun 2000
Location: SF Bay Area
Posts: 20,391
Does it work if you select ECON then MAX blower speed? If so, the blower motor brushes might be worn to where they need a "high amp" kick to start spinning.

Sixto
87 300D
Reply With Quote
  #5  
Old 11-28-2013, 06:59 PM
Zacharias's Avatar
Not so amused
 
Join Date: Apr 2010
Location: West Quebec
Posts: 4,025
Sixto, actually it has been working in the way you describe, just about since I owned the car. Now nothing wakes up the blower motor when in EC mode.

In the other modes (except DEF) the blower takes a very long time to kick in if the fan buttons are on low or auto. Kicks in right away on high, but EC won't respond even if I switch over to it from one of the other settings, once the blower is running.
__________________


Mac
2002 e320 4matic estate│1985 300d│1980 300td
Previous: 1979 & 1982 & 1983 300sd │ 1982 240d

“Let's take a drive into the middle of nowhere with a packet of Marlboro lights and talk about our lives.” ― Joseph Heller, Catch-22
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On




All times are GMT -4. The time now is 05:46 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2018, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2018 Pelican Parts, LLC - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page