Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help



Go Back   PeachParts Mercedes-Benz Forum > Mercedes-Benz Tech Information and Support > Diesel Discussion

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 03-29-2014, 08:13 PM
jia300d's Avatar
Registered User
 
Join Date: Jun 2013
Posts: 58
Sunroof advice needed !!

Hi, I am running out of ideas and I need some brain help. I've been working on the sunroof of my 87 300SDL. I replaced the arms because they were broken. Put all back together, it worked for a short while (open, close, tilt) and suddendly it stopped working. Not even a click when I push the Switch. I thought the motor went out but I removed the sunroof cable completely, tested the motor and it works fine (forward and backwards). Intalled the wire back, tried again and does not work. Not even a click. I am frustrated and out of ideas. Any thoughts our there? Thanks.

Reply With Quote
  #2  
Old 03-29-2014, 08:39 PM
toomany MBZ's Avatar
Registered User
 
Join Date: Nov 2006
Location: central Va
Posts: 7,820
Switch?
__________________
83 SD

84 CD
Reply With Quote
  #3  
Old 03-29-2014, 08:46 PM
Registered User
 
Join Date: Aug 2013
Location: Los Angeles area
Posts: 621
Yes, switch or a relay would be my first thoughts.
__________________
1983 W123 300TD US spec Turbo engine, with Euro bumpers and manual climate control, and manual transmission.
Reply With Quote
  #4  
Old 03-29-2014, 09:24 PM
toomany MBZ's Avatar
Registered User
 
Join Date: Nov 2006
Location: central Va
Posts: 7,820
Are you able to move the roof manually?
__________________
83 SD

84 CD
Reply With Quote
  #5  
Old 03-30-2014, 09:30 AM
jia300d's Avatar
Registered User
 
Join Date: Jun 2013
Posts: 58
I checked the switch and it works fine. It operates the motor (without the cable) in both directions. I visually checked the rotation of the nut in the Manual OPEN/CLOSE mechanism and it rotates both clockwise and counter when operating the switch in both directions.

I can also OPEN & CLOSE manually with the cable installed without much effort, just by turning it with pliers.

This makes me think of a relay that could trip and cut the motor off if the sunroof cable becomes hard to push. I noticed when I insert the cable into the tube is that it slides very smoothly along the straight section, then when the tube turns to the side (at the end of the roof) and then down towards the motor, I have to push the cable in harder. My thought is that it is because it reached the gears and I have to push harder to make the wire go through the gears. BUT, although I can operate it manually without a problem it could still be too heavy for the motor. I know where the fuse is and it is OK but I could not locate a relay for the sunroof in the manual. If you know where it is, please let me know. Thanks!

Last edited by jia300d; 03-30-2014 at 09:42 AM.
Reply With Quote
  #6  
Old 03-30-2014, 12:28 PM
Registered User
 
Join Date: Aug 2013
Location: Los Angeles area
Posts: 621
This thread might provide some help. Electrical stuff, isn't my forte. But, this might provide some insight as to how it works. W123 sunroof Closes, won't Open
__________________
1983 W123 300TD US spec Turbo engine, with Euro bumpers and manual climate control, and manual transmission.
Reply With Quote
  #7  
Old 03-30-2014, 02:43 PM
jia300d's Avatar
Registered User
 
Join Date: Jun 2013
Posts: 58
Thanks for the link Crazy4Diesel. Unfortunately I did all that, except for cleaning the tube real well . Since it was working fine before, I assume it is clean, but it won't not hurt if I do it. If you find something else, please send it this way.
Thanks again!
Reply With Quote
  #8  
Old 03-30-2014, 08:42 PM
jia300d's Avatar
Registered User
 
Join Date: Jun 2013
Posts: 58
PROBLEM SOLVED - It was something very stupid I neglected to do. I was not tightening the clutch before operating the switch, therefore there was no engagement of the cable. Thanks for the help.
Reply With Quote
  #9  
Old 03-30-2014, 10:19 PM
Registered User
 
Join Date: Aug 2013
Location: Los Angeles area
Posts: 621
Congrats, I kinda figured when you went through all the steps again, it'd all come together for you. Glad for you, you solved it.
__________________
1983 W123 300TD US spec Turbo engine, with Euro bumpers and manual climate control, and manual transmission.
Reply With Quote
  #10  
Old 03-31-2014, 08:14 AM
toomany MBZ's Avatar
Registered User
 
Join Date: Nov 2006
Location: central Va
Posts: 7,820
Glad to hear it.

__________________
83 SD

84 CD
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On




All times are GMT -4. The time now is 10:10 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2022, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2018 Pelican Parts, LLC - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page