Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help



Go Back   PeachParts Mercedes-Benz Forum > Mercedes-Benz Tech Information and Support > Diesel Discussion

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 06-07-2014, 12:33 AM
Registered User
 
Join Date: Aug 2011
Location: N. TX
Posts: 180
Check Engine Oil Level Warning light

I have been getting the warning usually on 20+ mile trips. But when I check the Oil it is correct and recheck after it has been garaged overnight and the level is correct.

I am running Valvoline 5w40 Synthetic, the car runs perfect and has over 278k miles. Is this oil too thin for Dallas weather?

Any clue(s) as to why this may be happening?

__________________
06 MB E320 CDI 111k miles
14 Sienna (wife's DD) 36k miles
11 GL350 Bluetec 136k (Sold)
96 E300; 292k+ miles (Donated)
11 Sprinter 22K+ miles (Sold)
Reply With Quote
  #2  
Old 06-07-2014, 01:08 AM
Jeremy5848's Avatar
Registered Biodiesel User
 
Join Date: Mar 2006
Location: Sonoma Wine Country
Posts: 8,394
My '96 E300 also uses 5W-40 synthetic and the low oil warning is quite conservative. It starts complaining a quart too soon, IMO. My '95 E300 is similar.
__________________

"Buster" in the '95

Our all-biodiesel family
1995 E300D (W124) . .239,000 miles My car
1996 E300D (W210) . .313,000 miles Wife's car
Santa Rosa population 170,685 (2012)
Total. . . . . . . . . . . . 722,685
"Oh lord won't you buy me a Mercedes Benz."
-- Janis Joplin, October 1, 1970
Reply With Quote
  #3  
Old 06-07-2014, 02:22 AM
Registered User
 
Join Date: Mar 2009
Location: San Diego
Posts: 2,978
This a possibility as it happens to my 300SDL but it is not the same car. The o-ring on the oil filter stick is worn or not exist. Oil is drained back from oil filter to the tank when stationary or over-night. Oil level is correct every time I measure it but it is low when oil is pumped back to the oil filter. So check the O-ring next time you change your oil.
__________________
Not MBZ nor A/C trained professional but a die-hard DIY and green engineer. Use the info at your own peril. Picked up 2 Infractions because of disagreements. NOW reversed.

W124 Keyless remote, PM for details. http://www.peachparts.com/shopforum/mercedes-used-parts-sale-wanted/334620-fs-w124-chasis-keyless-remote-%2450-shipped.html

2 x 87 300SDL
1 x 87 300D
1 x 87 300TDT wagon
1 x 83 300D
1 x 84 190D ( 5 sp ) - All R134 converted + keyless entry.
Reply With Quote
  #4  
Old 06-07-2014, 05:25 AM
Registered User
 
Join Date: Jul 2004
Location: Barrington, RI
Posts: 5,522
The sending unit could be going bad.
__________________
06 E320 CDI "Benson", Platinum Blue, 176k mi
06 E320 CDI "Rutherford", Black, 149k mi
91 300D "Otis", Smoke Silver, 130k mi
98 E300 "Murray", Silver, 133k mi, Stage 2 Rocketchip chip tuned (FOR SALE)

Twelve other MB's owned and sold
2002 Honda Odyssey 260k mi (want to name it "Homer," wife won't let me)
1961 Very Tolerant Wife
Reply With Quote
  #5  
Old 06-07-2014, 11:50 AM
Registered User
 
Join Date: Aug 2011
Location: N. TX
Posts: 180
Thanks everybody for your response, glad that it is not my aging engine.

I do change the "O" rings every time I change oil. "SherTX" may be correct regarding the sending unit.
__________________
06 MB E320 CDI 111k miles
14 Sienna (wife's DD) 36k miles
11 GL350 Bluetec 136k (Sold)
96 E300; 292k+ miles (Donated)
11 Sprinter 22K+ miles (Sold)
Reply With Quote
  #6  
Old 06-07-2014, 11:07 PM
Registered User
 
Join Date: May 2007
Location: Pollock, LA
Posts: 208
My 91 350SDL has the light on for a while each morning when I start up cold, it stays on maybe 3 minutes. Then it will go out and not see it again all day. I'm not sure whats up with that, but I ignore it. It is not low on oil.
__________________
1991 350SDL 350k+ miles
Reply With Quote
  #7  
Old 06-08-2014, 12:10 AM
Registered User
 
Join Date: Aug 2011
Location: N. TX
Posts: 180
I need to clarify one thing my Oil Level Warning light comes on while while I am on the Freeway cruising 65-70 MPH. Light does not come on when I start and only when it is at full operating temp. I wonder if that makes a difference.
__________________
06 MB E320 CDI 111k miles
14 Sienna (wife's DD) 36k miles
11 GL350 Bluetec 136k (Sold)
96 E300; 292k+ miles (Donated)
11 Sprinter 22K+ miles (Sold)
Reply With Quote
  #8  
Old 06-08-2014, 12:23 AM
VW1300's Avatar
Registered User
 
Join Date: Feb 2007
Location: Houston, TX
Posts: 463
Shortly after I got my '97 my oil level warning came on doing 70 mph - got home and the dipstick read half full. Only other time was right after I changed the oil once, again the dipstick read (only) half full. So just saying, my sensor is pretty fussy, I keep it at 3/4 full.

Suggestion - If it isn't already, carefully add oil so it reads near the top line on the dipstick, and see if the warning light stops coming on.

__________________
Charlie

---------------------------
'66 VW 1300 96K miles
'97 E300D 239K miles
'85 300D 203K miles (sold Sep 2012)


Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On




All times are GMT -4. The time now is 03:51 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2018 Pelican Parts, LLC - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page