Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help




Go Back   PeachParts Mercedes-Benz Forum > Mercedes-Benz Tech Information and Support > Diesel Discussion

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 08-27-2014, 03:49 PM
Registered User
 
Join Date: Aug 2009
Posts: 237
84 123 300dt

84 300dt. The car starts and idles OK, but when accelerating sputters shaking smoke like crazy, then at 2800rpm smooth's out and runs fine. Valves adjusted great compression. I'm going to check the injectors, but it doesn't sound like injectors to me. Any thoughts?
Reply With Quote
  #2  
Old 08-27-2014, 04:16 PM
t walgamuth's Avatar
dieselarchitect
 
Join Date: Apr 2005
Location: Lafayette Indiana
Posts: 34,334
Checked your fuel filters yet?
__________________
[SIGPIC] Diesel loving autocrossing grandpa Architect. 08 Dodge 3/4 ton with Cummins & six speed; I have had about 35 benzes. I have a 39 Studebaker Coupe Express pickup in which I have had installed a 617 turbo and a five speed manual.[SIGPIC]

..I also have a 427 Cobra replica with an aluminum chassis.
Reply With Quote
  #3  
Old 08-27-2014, 05:40 PM
Registered User
 
Join Date: Aug 2009
Posts: 237
Changed those first.
Reply With Quote
  #4  
Old 08-27-2014, 08:57 PM
Jesus'd drive a diesel
 
Join Date: Jun 2014
Location: Chicago,IL
Posts: 230
Timing??
__________________
General George - 1967 Land Rover 2a SWB 1983 OM617 Turbo
Reply With Quote
  #5  
Old 08-27-2014, 10:22 PM
Registered User
 
Join Date: Jul 2008
Posts: 3,740
Bad motor mount and or trans mount
Clogged tank strainer
Fuel leak from rotted hose
Fuel pressure relief valve
Rack damper bolt
injection pump timing
bad injectors
alda cleaning
air filter
clogged intake/exhaust from failed EGR valve

Could be any of those, a combination of those or all of those..
__________________
Reply With Quote
  #6  
Old 08-29-2014, 06:55 PM
Registered User
 
Join Date: Aug 2009
Posts: 237
I checked the injectors. They looked good. I'm going to change the alda and check the egr.
Reply With Quote
  #7  
Old 08-29-2014, 07:42 PM
uberwasser's Avatar
1979 & 1985 300D's
 
Join Date: Oct 2012
Location: Tucson, AZ
Posts: 1,097
It's not really possible to check your injectors visually. They need to be tested for opening pressure, to ensure they are within spec and all are balanced with each other.
__________________
1979 300D 040 Black on Black - 1985 300D Maaco job (sadly sprayed over 199 Black Pearl Metallic) on Palamino

http://i.imgur.com/LslW733.jpg

The Baja Arizona Oil Burners Send a message if you'd like to join the fun
Left to Right - UberWasser, Iridium, Stuttgart-->Seattle,, mannys9130

Visit the W123 page on iFixit for over 70 helpful DIY guides!
Reply With Quote
  #8  
Old 08-29-2014, 07:46 PM
dude99's Avatar
Registered User
 
Join Date: Nov 2009
Location: Vancouver, BC
Posts: 1,401
When you "checked" the injectors, did you put new copper heat shields in? If not you could have a compression leak.
__________________
2003 Volvo V70 5 Speed
1997 E290 Turbo Diesel Wagon -traded for above, an amazingly comfortable car to drive, great drivetrain, but the rust, oh my god the rust
1992 BMW 525i -traded in
1990 Silver 300TE -Sold Loved the wagon, hated the M103
1985 Grey 380SE Diesel Conversion, 2.47 rear end, ABS -Sold, really should have kept this one
1979 Silver 300D "The Silver Slug" -Sold
Reply With Quote
  #9  
Old 08-29-2014, 08:06 PM
Diesel911's Avatar
Registered User
 
Join Date: Sep 2007
Location: Long Beach,CA
Posts: 28,257
Quote:
Originally Posted by dude99 View Post
When you "checked" the injectors, did you put new copper heat shields in? If not you could have a compression leak.
The Heat Shields on Mine are Steel. Victor Reinz makes Steel Heat Shields that are Cadnium (spelling?) Plated and they are sort of brass colored.
__________________
84 300D, 82 Volvo 244Gl Diesel
Reply With Quote
  #10  
Old 08-29-2014, 08:07 PM
Diesel911's Avatar
Registered User
 
Join Date: Sep 2007
Location: Long Beach,CA
Posts: 28,257
If you have a Old Style Hand Primer with the Shiny Aluminum Body My Guess is an Air Leak. But you can have a Air Leak in the Fuel Inlet Hoses or Plastic Primary Filter also.
__________________
84 300D, 82 Volvo 244Gl Diesel
Reply With Quote
  #11  
Old 09-03-2014, 03:11 PM
Registered User
 
Join Date: Aug 2009
Posts: 237
I took the egr off made a gasket with out a hole for exhaust put it back on and now it runs fine. thank you for your help.
Reply With Quote
  #12  
Old 09-03-2014, 03:36 PM
Jesus'd drive a diesel
 
Join Date: Jun 2014
Location: Chicago,IL
Posts: 230
Man, that was easy enough.
__________________
General George - 1967 Land Rover 2a SWB 1983 OM617 Turbo
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On




All times are GMT -4. The time now is 07:24 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2018 Pelican Parts, LLC - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page