Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help



Go Back   PeachParts Mercedes-Benz Forum > Mercedes-Benz Tech Information and Support > Diesel Discussion

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 09-26-2014, 06:04 PM
bsmuwk's Avatar
124.051
 
Join Date: Jan 2009
Location: IL / WI
Posts: 1,000
190D and a 722.4 Shifting Conundrum 1st to 3rd

Car was shifting nicely after I changed out the K1 and K2 spring kits, still does otherwise though.

I came to a stop sign (made a full stop) and when taking off it started out in 1st rather than the usual 2nd. From there, revved up to 3000 before shifting to 2nd then immediately to 3rd. Then proceeded to shift normally to 4th after I've built up enough speed.

Shifts from 1st to 3rd all under 20mph. I can occasionally get it to grab 2nd and go as if nothing happened. It's not slipping. Bowden cable is properly adjusted and vacuum modulator was replaced when I did the K1/K2 service and was properly adjusted. Shifts are quick, crisp and not neck snapping.


Kickdown switch is working properly.

Any ideas? Just happened randomly. Found it a bit odd.

__________________
Allen Kroliczek
Oak Grove Autosport
01 G500, 82 300TD, quite a few more.....
Reply With Quote
  #2  
Old 09-26-2014, 06:58 PM
bsmuwk's Avatar
124.051
 
Join Date: Jan 2009
Location: IL / WI
Posts: 1,000
" Transmission Slips In 2nd Gear Or Shifts From 1st To 3rd Gear
Check control valve B-1 for ease of operation. Replace valve
body (if necessary). Remove and install brake band piston B-1, check
sealing ring and replace (if necessary). Replace brake band B-1 and
thrust body for B-1. Command valve binding. "

Seems like this in relation to B1 system.

Time for more research before I go and rip out this valve body.
__________________
Allen Kroliczek
Oak Grove Autosport
01 G500, 82 300TD, quite a few more.....
Reply With Quote
  #3  
Old 09-27-2014, 10:58 PM
bsmuwk's Avatar
124.051
 
Join Date: Jan 2009
Location: IL / WI
Posts: 1,000
Took valve body out of trans today. B1 spring had a crack and a coil broke off. Sacrificed B1 system from another trans i had as core with dead reverse.

Car is shifting wonderfully with new B1 system and K1/K2 replacement spring sets. Like damn butter!

Forgot to take pics - but if anyone is having issues with a 1st to kinda 2nd then to 3rd shift, your B1 system is weak.
__________________
Allen Kroliczek
Oak Grove Autosport
01 G500, 82 300TD, quite a few more.....
Reply With Quote
  #4  
Old 09-29-2014, 12:12 PM
Registered User
 
Join Date: Nov 2010
Location: Ooltewah, TN
Posts: 707
Good info - thanks for sharing!

__________________
You can't always get what you want, but if you try sometime you just might find you get what you need.
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On




All times are GMT -4. The time now is 06:31 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2022, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2018 Pelican Parts, LLC - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page