Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help




Go Back   PeachParts Mercedes-Benz Forum > Mercedes-Benz Tech Information and Support > Diesel Discussion

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 11-03-2014, 10:56 PM
Registered User
 
Join Date: Apr 2014
Location: Huatulco, Oaxaca, Mexico
Posts: 110
glow plug light blinks after starting

All of a sudden the glow plug light began to blink after the car is started. It blinks for maybe one minute and then stops.

Otherwise everything acts normally. The car starts fine.

It's a 1980 300D.

What could this be? The factory shop manual lists all kinds of troubleshooting problems that occur with the relay, but it doesn't mention this.

Richard
Reply With Quote
  #2  
Old 11-03-2014, 11:18 PM
Zacharias's Avatar
Not so amused
 
Join Date: Apr 2010
Location: West Quebec
Posts: 4,025
At least one of your glowplugs is burned out or close to it.
__________________


Mac
2002 e320 4matic estate│1985 300d│1980 300td
Previous: 1979 & 1982 & 1983 300sd │ 1982 240d

“Let's take a drive into the middle of nowhere with a packet of Marlboro lights and talk about our lives.” ― Joseph Heller, Catch-22
Reply With Quote
  #3  
Old 11-03-2014, 11:21 PM
uberwasser's Avatar
1979 & 1985 300D's
 
Join Date: Oct 2012
Location: Tucson, AZ
Posts: 1,097
Does the W123 really have the blinking light for bad plugs? I mean, his is obviously blinking...but mine was not when I had a bad plug on my '85. I was under the impression that when enough plugs went out on the later style W123 setup the light simply wouldn't light.

Slightly confused as to this. I thought the blinking was a post-W123 thing.
__________________
1979 300D 040 Black on Black - 1985 300D Maaco job (sadly sprayed over 199 Black Pearl Metallic) on Palamino

http://i.imgur.com/LslW733.jpg

The Baja Arizona Oil Burners Send a message if you'd like to join the fun
Left to Right - UberWasser, Iridium, Stuttgart-->Seattle,, mannys9130

Visit the W123 page on iFixit for over 70 helpful DIY guides!
Reply With Quote
  #4  
Old 11-04-2014, 01:40 AM
Diesel911's Avatar
Registered User
 
Join Date: Sep 2007
Location: Long Beach,CA
Posts: 25,187
Check the Glow Plugs with an Ohm Meter (don't recommend buying Parts there) go to the Diesel Giant Site under Glow Plug Repair and there is a pictorial on how to check with the Ohm Meter.

Check the Strip Fuse on the Glow Plug Relay for a crack; the crack can be hard to see (this happend to me). Check the Screws that hold it down to see if they are loose.

The Engine will start with one bad Glow Plug. After it starts does it sould like there is one Injector that is more noisy?
__________________
84 300D, 82 Volvo 244Gl Diesel
Reply With Quote
  #5  
Old 11-04-2014, 09:50 AM
psaboic's Avatar
Registered User
 
Join Date: Jun 2004
Location: SW Washington Coast
Posts: 764
I had the same issue a couple years ago. After checking all the glow plugs it turned out that the glow plug relay had gone bad.............
__________________
2017 Santa Fe 27K (hers)
2002 VW Jetta TDI 194K (mine)
1998 Volvo S70 T5 Turbo 137K (kids)
1992 Ford F150 4WD 258K (wood getter)
1983 Mercedes 300D 330K (diesel commuter)
1965 Corvair Corsa 98K (fun car)
Reply With Quote
  #6  
Old 11-04-2014, 10:29 AM
Registered User
 
Join Date: Sep 2007
Location: Calgary Alberta Canada
Posts: 1,171
Sounds like you may have a GP relay from another car. Blinking light indicates a short. How is your car starting?
Reply With Quote
  #7  
Old 11-04-2014, 12:26 PM
Zacharias's Avatar
Not so amused
 
Join Date: Apr 2010
Location: West Quebec
Posts: 4,025
My w116 300sd (1979) glow plug light blinked when I had defective plug(s), I know because it happened just after I got it and it was my first diesel. It scared the wits out of me.... So I was going by that (same relay style as my 1980 wagon, so I assumed same for his car?).

Now that I think on it, am pretty sure my wagon blinked its light at me at one point too.
__________________


Mac
2002 e320 4matic estate│1985 300d│1980 300td
Previous: 1979 & 1982 & 1983 300sd │ 1982 240d

“Let's take a drive into the middle of nowhere with a packet of Marlboro lights and talk about our lives.” ― Joseph Heller, Catch-22
Reply With Quote
  #8  
Old 11-04-2014, 07:55 PM
Registered User
 
Join Date: Apr 2014
Location: Huatulco, Oaxaca, Mexico
Posts: 110
Quote:
How is your car starting?
The car starts perfectly. Instantaneously. Couldn't ask for better. Of course I live where it is eternal summer.

I have a set of new glow plugs and a reamer but with the car starting like this I am not at all motivated to install them.

Richard
Reply With Quote
  #9  
Old 11-04-2014, 09:15 PM
Registered User
 
Join Date: Feb 2013
Location: South carolina
Posts: 47
It could also be a short in the glow plug ground circuit.
__________________
1983 300SD
1988 420SEL
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On




All times are GMT -4. The time now is 01:13 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2018, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2018 Pelican Parts, LLC - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page