Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help




Go Back   PeachParts Mercedes-Benz Forum > Mercedes-Benz Tech Information and Support > Diesel Discussion

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 11-04-2014, 02:10 AM
Registered User
 
Join Date: Apr 2011
Location: UpState NY
Posts: 12
Angry 87' 300D Another no start or sometimes start problem

Some times it starts right up and then try again and nothing. All I might hear is a click when I turn the key off.

Some history: I have been pouring tons of time into this girl

New glow plugs
Rebuilt injectors
IP seals replaced at same time
Recent new battery
Replaced ground strap on motor
Harness wire replaced as it shorted out and I almost had a barbaque
New harness housing
New 50 AMP GP fuse
Removed and cleaned fuel tank and new strainer
All new filters
Resealed Vacuum pump
New radiator
New alternator brushes
New copper fuses

I purchase lots of stuff from Kent Bergsma (Moly, rebuild kits, hoses, connectors, tools. etc.) I know a little pricey at times but usually worth it in what you get the added knowledge you receive with the parts.

I purchased a new ignition switch. and electrical switch connector for it. But cannot seem to see how it could be even remotely possible to replace them. At this point I am totally stumped.

So I follow the ideas regarding NSS posted here and elsewhere and go thru the gears then put it park and pow she starts right up. No glow plugs waiting or anything. Pretty sure it is my NSS in this case but am going to try in the morning same thing and see if I can start it without playing with the shifter. Guess we'll have to see about this.

Started the car early in the day and let it sit idling for awhile. All of a sudden it ran away on me. Total red line. Flew out of the house and shut it off. Then no start at all after that for the rest of the afternoon. Go out at 5:30 and got it going again with my OLD key, geez. WTF. Now I am not sure what is causing my no start problem. Do I replace the lock tumbler and the NSS? Could really use a bump here people. And what about the Alternator/Starter harness?
Reply With Quote
  #2  
Old 11-04-2014, 04:40 PM
Registered User
 
Join Date: Jun 2004
Location: West of Ft. Worth. TX
Posts: 4,079
I'm getting conflict here, due to your list. Are you defining "no-start" as the starter isn't engaging and turning the engine over? or cranks over fine but won't fire?

The reason I ask is they are two different issues. I'm assuming it is the first problem we are dealing with. Sometimes the problem with the NSS isn't the switch itself but worn shifter bushings instead.
__________________
Sam

84 300SD 350K+ miles ( Blue Belle )
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On




All times are GMT -4. The time now is 05:03 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2018, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2018 Pelican Parts, LLC - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page