Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help




Go Back   PeachParts Mercedes-Benz Forum > Mercedes-Benz Tech Information and Support > Diesel Discussion

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 04-30-2002, 08:15 PM
190D22's Avatar
Driver's Side lights
 
Join Date: Apr 2002
Location: Columbus, Ohio
Posts: 876
Cruise Control Supposedly never worked right on my car...????

The gentleman I bought my car off of said that the cruise control never worked properly off of the lot. He said it's been in numerous times for the cruise control, and still it never worked consistantly. Well it's never worked for me, not even once. I looked at the throttle on the engine and the bar from the cruise control unit to the throttle wasn't secure and it didn't even fit on the cruise control unit. After I had her in at mercedes (not for cruise control work) I noticed while charging my AC that the bar was now completely gone, it's almost like they said "oh you don't need this, it doesn't work anyway." which makes me mad! I would like to have cruise control, I use it a lot in my jeep. What would a complete cruise control system replacement cost (parts labor, etc)? OR what could the problem be, other than that bar not being there.
__________________
1984 190D 2.2 Auto 220k
2001 Jeep Cherokee Sport 70K
2004 Lexus RX-330 ??K
2005 Chrylser Crossfire LTD 6K

Play guitar? Go to www.cyberfret.com for free online lessons!
Reply With Quote
  #2  
Old 04-30-2002, 10:45 PM
gsxr's Avatar
Unbanned...?
 
Join Date: Aug 2001
Location: USA
Posts: 8,002
The cruise control amps (box under the dash) is the most common failure. They are ~$150 for a rebuilt. Some folks try "resoldering" the old ones, but that seems to work better on older ones (W116, W123) and not so much on the newer ones (W124, W201, etc). Your actuator (on the engine) could be bad as well but it's a lot less likely. The amp is pretty fragile electrically. All of my cars either have a rebuilt unit installed or need one!
__________________
Dave M.
Boise, ID

1997 E420 - 155kmi (Bugeyes)
1994 E420 - 145kmi (Blondie)
1993 500E - 193kmi (Lollipop)
1992 400E - 189kmi (Stinky Dirty)
Check out my website photos, documents, and movies!
Reply With Quote
  #3  
Old 05-01-2002, 03:09 PM
190D22's Avatar
Driver's Side lights
 
Join Date: Apr 2002
Location: Columbus, Ohio
Posts: 876
How do I determine it is definately the amp and not that actuator? I don't want to start tearing my car apart and come to find out that it's not what needed done?

Is that arm that goes between the actuator and the throttle easy to find and expensive? Thanks for the reply, man.
__________________
1984 190D 2.2 Auto 220k
2001 Jeep Cherokee Sport 70K
2004 Lexus RX-330 ??K
2005 Chrylser Crossfire LTD 6K

Play guitar? Go to www.cyberfret.com for free online lessons!
Reply With Quote
  #4  
Old 05-01-2002, 03:51 PM
gsxr's Avatar
Unbanned...?
 
Join Date: Aug 2001
Location: USA
Posts: 8,002
I don't know of a way to test, other than to get a rebuilt amp, install it, and see if it works. If not, then it's most likely the actuator. I'm assuming you've checked the fuses, electrical connections, etc. I'm not familiar with the linkages on your car specifically, but if it's anything like my cars, the little link arm (with a ball socket on each end) is available from any dealer (or online MB parts place) relatively cheap.


HTH,
__________________
Dave M.
Boise, ID

1997 E420 - 155kmi (Bugeyes)
1994 E420 - 145kmi (Blondie)
1993 500E - 193kmi (Lollipop)
1992 400E - 189kmi (Stinky Dirty)
Check out my website photos, documents, and movies!
Reply With Quote
  #5  
Old 05-01-2002, 06:03 PM
jbaj007's Avatar
Registered User
 
Join Date: Jun 2001
Location: Santa Monica, CA
Posts: 2,053
This site will help you with the neccessary test (amp. draw) for the actuator. http://gdl-online.com/testproc.html
__________________
The Golden Rule

1984 300SD (bought new, sold it in 1988, bought it back 13 yrs. later)
Reply With Quote
  #6  
Old 05-01-2002, 08:10 PM
190D22's Avatar
Driver's Side lights
 
Join Date: Apr 2002
Location: Columbus, Ohio
Posts: 876
Hey thanks a lot! When I get the time, I will try those tests and possibly contact them. Thanks again guys!
__________________
1984 190D 2.2 Auto 220k
2001 Jeep Cherokee Sport 70K
2004 Lexus RX-330 ??K
2005 Chrylser Crossfire LTD 6K

Play guitar? Go to www.cyberfret.com for free online lessons!
Reply With Quote
  #7  
Old 12-28-2002, 03:17 PM
waybomb's Avatar
Registered User
 
Join Date: Nov 2002
Location: St. Joe, MI; Manitowoc, WI
Posts: 1,553
Hi all
Looking for diagnostic procedure to troubleshoot cruise control problem. Did a search and came up with this thread. Tried the "gdl" site mentioned above, but I can not get it. Has it moved? Any other sites that provide a test procedure?
Or maybe you can help me....
Recently bought a 82 300SD. The po said the cruise did not work, and gave me another amp that he thought did work. When driving back from Florida to Wisconsin, it did not work until about Illinois. The cruise worked for about a hundred miles then stopped working again. Today, a "warm" day in Wisconsin, I changed out the amp. Still does not work. It is possible the replacement amp was not good either, but before I buy a new/rebuilt unit, I'd like to be sure.
Can anybody provide some troubleshooting advice?
Thank You
Fred Konchan
Reply With Quote
  #8  
Old 12-28-2002, 04:13 PM
lrg lrg is offline
Registered User
 
Join Date: Jul 2001
Location: San Francisco
Posts: 1,163
It's www.gdl-online.com. The company name is General Development Labratories. I just tried to pull it up directly and through Google and I couldn't. They must be having server problems. They are listed on Google. They rebuilt amps from both my cars and both work great. There's also some helpful stuff on the website about testing the acuator but it takes some looking, it's not the best website.
__________________
LRG
1987 300D Turbo 175K
2006 Toyota Prius, efficent but no soul
1985 300 TDT(130K miles of trouble free motoring)now sold
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On




All times are GMT -4. The time now is 06:43 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2018 Pelican Parts, LLC - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page