Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help




Go Back   PeachParts Mercedes-Benz Forum > Mercedes-Benz Tech Information and Support > Diesel Discussion

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 05-31-2015, 05:25 PM
Registered User
 
Join Date: Jan 2009
Location: Manchester,NH
Posts: 392
1996 Mercedes E300D

Hey Guys,

I have a check engine light on because of a coolant temp sensor. I wanted to replace the sensor iteself to start with, but I cannot find where it is located.
Can you guys help me out? Where is the coolant temp sensor located?

Also wanted to replace the coolant level sensor, but do not see it on the expansion tank. Where would this sensor be?
Reply With Quote
  #2  
Old 05-31-2015, 05:50 PM
bsmuwk's Avatar
124.051
 
Join Date: Jan 2009
Location: IL / WI
Posts: 939
Coolant temp sensor is located under the intake manifold, remove center intake pipe (couple 10mm bolts) and it will be rearward of the center pipe.

There are two per car, one for the gauge and one for fuel injection, part # 0115425117

#23 in the picture is the coolant temp sensor
Attached Thumbnails
1996 Mercedes E300D-sensor.jpg  
__________________
-Allen
Lakemoor, IL
Artisan Motorenbau
Chicagoland Mercedes Enthusiast Facebook Group: https://www.facebook.com/groups/mbclubchicago/
Reply With Quote
  #3  
Old 05-31-2015, 10:36 PM
KarTek's Avatar
<- Ryuko of Kill La Kill
 
Join Date: Jun 2007
Location: Bahama/Eno Twp, NC
Posts: 3,256
If you're getting the "coolant level sensor malfunction" message, it's likely the washer fluid sensor since both sensors are wired in series.

If it turns out you need the coolant level sensor, I have a brand new one I will sell you at a discount from the new price.
Reply With Quote
  #4  
Old 07-08-2015, 05:51 PM
Registered User
 
Join Date: Jan 2009
Location: Manchester,NH
Posts: 392
I still have one question regarding the coolant temp sensor.

The gauge is working correctly and showing the temperature. I am getting a check engine light because of a coolant temp sensor. I know that there are 2 sensors one for the gauge and the other for the fuel management. The problem I am also having is increased fuel consumption. The sensor under the intake, which one is that? is that for the gauge or for the engine control module?
Reply With Quote
  #5  
Old 07-08-2015, 05:54 PM
Registered User
 
Join Date: May 2009
Location: The slums of Beverly Hills
Posts: 6,112
That's the ECU ECT. Have you rebuilt your k40 relay yet? ECT was one of the codes I was getting prior to fixing the relay. I ended up buying the sensor but never installed.
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On




All times are GMT -4. The time now is 12:39 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2018 Pelican Parts, LLC - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page