Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help




Go Back   PeachParts Mercedes-Benz Forum > Mercedes-Benz Tech Information and Support > Diesel Discussion

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 06-21-2016, 10:40 AM
Registered User
 
Join Date: Sep 2012
Location: Wilmington, NC by the Atlantic ocean
Posts: 2,359
How Fast Can An OM617 Go? Phase II

Mutt and I got back yesterday. I have a GoPro of one of my runs but I'm having "issues" with posting it but once I sort this out I'll get it out to y'all.

So the bottom line - 3 runs, 3 record bumps.

The first run on Sat. AM. I'm a bit groggy in the morning and while waiting in line Dick (the Volvo owner) asked if I had ice in the intercooler cooler. The answer was "D'oh". I had forgotten the ice AND the GoPro. So I went ahead and made the first run anyhow. 123.5246 - about 2 MPH better than my best run at the last meet. Boost was at about 17PSI.

So we went to lunch and got ice and the GoPro from the motel room. I got back in line and right at the starting line we had a hold on the course for 5 minutes or so. I shut the engine off and waited but I had forgotten that the intercooler pump runs with the engine kill switch off (got to move that power source!) so the ice was completely melted when I got back to the pits after the run - so idea if I had ice for the run or not. I did, however, get the GoPro footage that I can watch on my computer screen so now I just have to switch formats. 126.9752 - another couple of MPH to my record. I had bumped the boost again to about 19PSI.

So I hung it up for the day and Dick headed home (he still does that work thing).

So on Sunday AM I added new ice (the stuff in Ohio keeps turning into water - I need to bring better ice) bumped the boost a tad more to probably 20 or so (I didn't have time to look at it during the run) and headed down the track with cooler air given that it was in the morning. This run - 128.3880 and that was into a head wind (really, you can ask Brian!). I was hoping for a 130 but I guess that will be in September.

In the staging lane my shut-off system stopped working so I'll need to track that down along with a couple of other minor glitches. The new clutch was flawless so that was a great success - sintered copper works!

Hope to get the video up soon.

Dan
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On




All times are GMT -4. The time now is 07:39 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2018, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2018 Pelican Parts, LLC - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page