PeachParts Mercedes-Benz Forum

PeachParts Mercedes-Benz Forum (http://www.peachparts.com/shopforum/)
-   Diesel Discussion (http://www.peachparts.com/shopforum/diesel-discussion/)
-   -   240D Vacuum's Back (http://www.peachparts.com/shopforum/diesel-discussion/38931-240d-vacuums-back.html)

JohnM 05-30-2002 01:13 AM

240D Vacuum's Back
 
About a week ago I abruptly lost vacuum in my 83 240D (wouldnít shut off, locks didnít work, etc.). After determining that I didnít have any obvious leaks or disconnected vacuum tubes, I searched this forum and figured that I probably had the piston type pump? I thought I would buy a vacuum gauge and do some testing this weekend and rebuild the pump if it was the problem. Yesterday I noticed the vacuum was returning slightly. Today everything is back to normal. My best guess since leaks donít repair themselves is that a check valve must have hung up and/or had some debris in it. Well, I learned a long time ago that once something fails it almost always does it again. Does a check valve sound like a likely candidate? I saw a posting that these can be changed without removing the pump from the engine by taking the cover off with the pump in place. Iím hoping it works that way.

JohnM
1983 240D 4sp manual 150K

SW 05-30-2002 09:13 AM

Sounds like the check valve to me. Mine was stuck in the port that goes to the brake booster hose.


All times are GMT -4. The time now is 06:13 PM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2020, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2018 Pelican Parts, LLC - Posts may be archived for display on the Peach Parts or Pelican Parts Website