Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help



Go Back   PeachParts Mercedes-Benz Forum > Mercedes-Benz Tech Information and Support > Diesel Discussion

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 01-22-2018, 04:59 PM
arcticathlon's Avatar
Registered User
 
Join Date: Aug 2005
Location: Richmond, Tx
Posts: 1,119
Need help with Instrument Cluster Lights behavior

I have a 91 350SDL and I am have the warning lights on the left side (half) slowly light up, as i press the throttle. I happens when i drive and when i am in park/Neutral. I have already checked the alternator and installed new voltage regulator, but that did nothing.

I have also pulled the cluster and ran 3 new ground wires from the 3 screws sticking out to the chassis and that did not fix it.

I think i am left with taking it apart, and checking the PCB. Currently, i have no specific areas of concern that I know of, that I should be focusing on. I will only be able to do a visual inspection for worn or broken traces, and would be lucky if i found any.

Have others seen this behavior on their W123, W124's or W126's?

I have searched the archives and have not been able to find anything on this issue directly. Lots of people talking about the Instrument Cluster Light Dimmer, but mine is operating just fine, and it is not the right lights anyway. Mine is with the warning lights.

Edit: One thing I forgot to add. The previous owner said that the issue started happening, Right after he had the Instrument cluster Odometer repaired at a local radio repair shop. He never took it back to have it addressed, but that supposedly is when it started happening. not sure how that circuitry is possibly connected to the warning lights.


Thanks,

__________________

Grey '91 350SDL 214k
Beige '81 240D 4 Speed 254k
Blue '82 300D 225k
White '95 E300D 46k SOLD
Blue '87 190D 2.5 Turbo 315k SOLD
Brown '80 240D 4 Speed 716k SOLD
Beige '80 300D N/A 119k SOLD
Blue '85 300D Model 186k T-Boned
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On




All times are GMT -4. The time now is 10:03 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2018 Pelican Parts, LLC - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page