Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help



Go Back   PeachParts Mercedes-Benz Forum > Mercedes-Benz Tech Information and Support > Diesel Discussion

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 06-02-2002, 07:49 PM
Registered User
 
Join Date: Apr 2002
Location: Tulsa, Oklahoma
Posts: 103
Intermittent turn signal problem?

Hey guys,

My 82 300D has an intermittent turn signal. Sometimes, it works fine. At other times, the light will come on, but the flasher doesn't work. At other times, none of the lamps work. Then, the next time you start her up, everything is normal. Did searches on flasher and turn signal problems, no luck. Anyone had this problem?

Thanks

Dave
1982 300D

__________________
Dave

1982 300D
352,000 miles
Reply With Quote
  #2  
Old 06-02-2002, 10:56 PM
Moderator
 
Join Date: Jul 2001
Location: Old Lyme, Connecticut
Posts: 3,596
Dave,

On my 1982 240D I have had a similar problem. That car is a manual transmission equipped item, and the relay is under the wood veneer part that has the cutout for the shift lever and (if you have them, which I don't on this car), electric windows, just in front of the cutout for the shift lever. On this car the connector for the relay gets loose and you have to push the relay back in. I have put some popsicle sticks under the connector to keep it upright so the relay does not sag backwards as I thought that was contributing to the problem. Now, when it decides to misbehave I push the relay back in and realign the popsicle sticks. Not a really good fix, but it works for a few years at a time. Good luck, Jim
__________________
Own:
1986 Euro 190E 2.3-16 (291,000 miles),
1998 E300D TurboDiesel, 231,000 miles -purchased with 45,000,
1988 300E 5-speed 252,000 miles,
1983 240D 4-speed, purchased w/136,000, now with 222,000 miles.
2009 ML320CDI Bluetec, 89,000 miles

Owned:
1971 220D (250,000 miles plus, sold to father-in-law),
1975 240D (245,000 miles - died of body rot),
1991 350SD (176,560 miles, weakest Benz I have owned),
1999 C230 Sport (45,400 miles),
1982 240D (321,000 miles, put to sleep)
Reply With Quote
  #3  
Old 06-03-2002, 12:40 AM
Holson Adi's Avatar
Registered User
 
Join Date: Jul 2001
Location: Boston, MA
Posts: 2,561
Yes, it is the relay problem.
Mine did that and after I took the wood shifter surround apart and played around with things below it, they all work fine.

However, the hazard flashers occasionally refuse to work.... stubborn relay. But, if you turn it on and off it usually un-stick itself.
__________________
2008 BMW 335i Coupe
Reply With Quote
  #4  
Old 06-03-2002, 08:25 AM
Registered User
 
Join Date: Apr 2002
Location: Tulsa, Oklahoma
Posts: 103
Thanks a bunch! I'll give it a try. I was beginning to think it had something to do with my cigarette butt in the tach amp repair. ( The tach started swinging in time with the turn signals)

Dave

__________________
Dave

1982 300D
352,000 miles
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On




All times are GMT -4. The time now is 03:23 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2020, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2018 Pelican Parts, LLC - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page