Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help




Go Back   PeachParts Mercedes-Benz Forum > Mercedes-Benz Tech Information and Support > Diesel Discussion

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 05-24-2018, 03:28 PM
Registered User
 
Join Date: May 2018
Posts: 13
Exclamation 190D 1989 2.5 can't find vacuum door pump

Hello, my w201 suddenly stoped locking doors, at first the rear drivers door started locking strange, some times it locked some not, then all the locking system is down, nothing happens

I've searched on manuals and all over internet and there is supposed to be a vacuum pump below the rear seat, so I went there, BUT THERE IS NO PUMP, there is nothing, no cables, no vacuum lines, no pump, nothing.

Maybe I'm searching for something that does not exists in my model, any ideas?
Thank you.
Reply With Quote
  #2  
Old 05-24-2018, 05:47 PM
Registered User
 
Join Date: Dec 2006
Posts: 2,703
There should be a foam rubber box under the right rear passenger seat. Open the box, the pump will be inside.
Reply With Quote
  #3  
Old 05-25-2018, 03:35 AM
Registered User
 
Join Date: May 2018
Posts: 13
Quote:
Originally Posted by Mxfrank View Post
There should be a foam rubber box under the right rear passenger seat. Open the box, the pump will be inside.
Strange but true, there is no foam rubber box, there is nothing there... I'll be posting some pictures today for you to see...
You are 100% sure that this mercedes model have this pump here and there is no other place to search for it?
Thank you.
Reply With Quote
  #4  
Old 05-25-2018, 04:21 AM
Registered User
 
Join Date: May 2018
Posts: 13
Here are the pics...
Attached Thumbnails
190D 1989 2.5 can't find vacuum door pump-image2.jpg   190D 1989 2.5 can't find vacuum door pump-image3.jpg   190D 1989 2.5 can't find vacuum door pump-image4.jpg  
Reply With Quote
  #5  
Old 05-25-2018, 05:51 AM
Registered User
 
Join Date: Jul 2004
Location: Barrington, RI
Posts: 5,329
I know my 1991 W124 has a pump in that location. But I also seem to recall that, prior to a certain year, there was no pump....the door locking just operated on the residual vacuum of the system.

Can you provide the VIN? Perhaps we can look in EPC.
__________________
06 E320 CDI "Benson", Platinum Blue, 172k mi, DD
91 300D "Otis", Smoke Silver, 126k mi, other DD
98 E300 "Murray", Silver, 124k mi, Stage 2 Rocketchip chip tuned, son's DD

Twelve other MB's owned and sold
2002 Honda Odyssey 234k mi (want to name it "Homer," wife won't let me)
1961 Very Tolerant Wife
Reply With Quote
  #6  
Old 05-25-2018, 06:16 AM
Registered User
 
Join Date: May 2018
Posts: 13
Quote:
Originally Posted by shertex View Post
I know my 1991 W124 has a pump in that location. But I also seem to recall that, prior to a certain year, there was no pump....the door locking just operated on the residual vacuum of the system.

Can you provide the VIN? Perhaps we can look in EPC.
That is one of my ideas, that the system runs without a separate pump...
The VIN is WDB2011261A487758
Reply With Quote
  #7  
Old 05-25-2018, 06:34 AM
Registered User
 
Join Date: Jul 2004
Location: Barrington, RI
Posts: 5,329
According to EPC, it should be just where Mxfrank said it should be. Part number is 124 800 21 48.
__________________
06 E320 CDI "Benson", Platinum Blue, 172k mi, DD
91 300D "Otis", Smoke Silver, 126k mi, other DD
98 E300 "Murray", Silver, 124k mi, Stage 2 Rocketchip chip tuned, son's DD

Twelve other MB's owned and sold
2002 Honda Odyssey 234k mi (want to name it "Homer," wife won't let me)
1961 Very Tolerant Wife
Reply With Quote
  #8  
Old 05-25-2018, 06:38 AM
Registered User
 
Join Date: May 2018
Posts: 13
Quote:
Originally Posted by shertex View Post
According to EPC, it should be just where Mxfrank said it should be. Part number is 124 800 21 48.
Ok great that's something good to know, but do you see the foam box in the pictures I've posted? I also tried to hit the bottom searching for some foam sound or cables, maybe vacuum lines, but it sounds metal... Do you think I'm not seeing it? I feel dumb
Reply With Quote
  #9  
Old 05-25-2018, 06:42 AM
Registered User
 
Join Date: May 2018
Posts: 13
Compare this image taken from https://www.pelicanparts.com/techarticles/Mercedes-190E/49-BODY-Replacing_Your_Vacuum_Supply_Pump/49-BODY-Replacing_Your_Vacuum_Supply_Pump.htm with mines:


Reply With Quote
  #10  
Old 05-25-2018, 06:47 AM
Registered User
 
Join Date: Jul 2004
Location: Barrington, RI
Posts: 5,329
Quote:
Originally Posted by charrua View Post
Ok great that's something good to know, but do you see the foam box in the pictures I've posted? I also tried to hit the bottom searching for some foam sound or cables, maybe vacuum lines, but it sounds metal... Do you think I'm not seeing it? I feel dumb
It looks like it simply isn't there...weird.
__________________
06 E320 CDI "Benson", Platinum Blue, 172k mi, DD
91 300D "Otis", Smoke Silver, 126k mi, other DD
98 E300 "Murray", Silver, 124k mi, Stage 2 Rocketchip chip tuned, son's DD

Twelve other MB's owned and sold
2002 Honda Odyssey 234k mi (want to name it "Homer," wife won't let me)
1961 Very Tolerant Wife
Reply With Quote
  #11  
Old 05-25-2018, 06:51 AM
Registered User
 
Join Date: May 2018
Posts: 13
Quote:
Originally Posted by shertex View Post
It looks like it simply isn't there...weird.
That's what I thought... REALLY WEIRD, I have searched all over without any luck... Maybe is somewhere else?

If this adds some information my central lock only locks the 4 doors, no trunk or fuel function.. Just locks all doors with the front keys or form inside with the drivers door... How can I diagnose this? do you think I need to disassembly my doors and start following the vacuum lines?
Reply With Quote
  #12  
Old 05-25-2018, 07:04 AM
Registered User
 
Join Date: Jul 2004
Location: Barrington, RI
Posts: 5,329
Quote:
Originally Posted by charrua View Post
That's what I thought... REALLY WEIRD, I have searched all over without any luck... Maybe is somewhere else?

If this adds some information my central lock only locks the 4 doors, no trunk or fuel function.. Just locks all doors with the front keys or form inside with the drivers door... How can I diagnose this? do you think I need to disassembly my doors and start following the vacuum lines?
If the system did work and now no longer works it would seem that you have a leak somewhere in the vacuum system. Do you own a mighty vac? If not that is your next purchase. Then itís a matter of troubleshooting the vacuum systemÖ Finding where the leak is l, going section by section, isolating different parts of the vacuum system.
__________________
06 E320 CDI "Benson", Platinum Blue, 172k mi, DD
91 300D "Otis", Smoke Silver, 126k mi, other DD
98 E300 "Murray", Silver, 124k mi, Stage 2 Rocketchip chip tuned, son's DD

Twelve other MB's owned and sold
2002 Honda Odyssey 234k mi (want to name it "Homer," wife won't let me)
1961 Very Tolerant Wife
Reply With Quote
  #13  
Old 05-25-2018, 07:53 AM
Registered User
 
Join Date: Dec 2006
Posts: 2,703
I would seem that someone has done some shade tree mods to "improve" and "simplify" your car. They may be running the door locks off the reservac, or maybe they've installed another pump somewhere. Unfortunately, you're on your own with this one. You'll have to follow the vacuum lines and see where they lead.
Reply With Quote
  #14  
Old 05-26-2018, 09:32 AM
Dr. Sternschnuppe's Avatar
Registered User
 
Join Date: May 2012
Location: CH
Posts: 524
Arrow

Huh.
This car has not central locking system from factory.
Reply With Quote
  #15  
Old 05-26-2018, 09:34 AM
Dr. Sternschnuppe's Avatar
Registered User
 
Join Date: May 2012
Location: CH
Posts: 524
Arrow

There is an aftermarket central locking system. I believe that it it electrical. So you need to check working elements in each doors, but firstly in driver's one.
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On




All times are GMT -4. The time now is 08:51 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2018, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2018 Pelican Parts, LLC - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page