Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help




Go Back   PeachParts Mercedes-Benz Forum > Mercedes-Benz Tech Information and Support > Diesel Discussion

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 05-26-2019, 10:30 PM
Registered User
 
Join Date: Feb 2014
Location: charlotte nc
Posts: 172
99 E300D shifting issues...

my wife's car is shifting oddly, but only after or during full throttle downshifts.



the first instance was when merging on the interstate from a cloverleaf interchange, so i was probably going <25 mph. i stomped the accelerator. the engine rpm's increased, way slower than it should have. like seconds slower, then it felt delayed engaging to actually GO.



the second, most recent was today. right lane must turn right, im in the left lane and spotted a tundra passing everyone on the right only to cut us all off at the last second. i decided to be a dick, and again, stomped it. downshifted well, although i still thought a little slow, got it into the higher rpm's. responding to my wife's insistence (riding shotgun at the time) i let off to slow down from 65ish in a 45 zone, and the trans stayed in the lower downshifted gear, which im guessing was 2nd. even after tapping the accelerator a few times, it STILL stayed in that lower gear. it wasn't until we slowed down a good bit at the upcoming light that it was ok.


my wife informed me she never "stomps it" or needs to, other than that, it shifts perfectly.



the winter/summer switch is in summer, and the asr is on.



other than that, i don't have much info.



thanks in advance for all the help!
__________________
'92 300D 2.5
'99 E300TD
Reply With Quote
  #2  
Old 05-26-2019, 11:06 PM
jay_bob's Avatar
Control Freak
 
Join Date: Oct 2011
Location: Columbia, SC
Posts: 3,428
W210 still has a physical kick down switch under the pedal (same as in the 124s). Check to make sure it's functioning correctly.

Since the problem is only happening at full pedal, I would see if that switch is binding.
__________________
The OM 642/722.9 powered family
2014 ML350 Bluetec (wife's DD)
2013 E350 Bluetec (my DD)
2008 ML320 CDI (Older sonís DD)
2008 E320 Bluetec (Younger son's DD)

1998 E300DT sold to TimFreeh
1987 300TD sold to vstech
----------
gone but living on
1983 240D (body to greazzer, engine to t walgamuth)
Reply With Quote
  #3  
Old 05-27-2019, 11:10 PM
Registered User
 
Join Date: Feb 2014
Location: charlotte nc
Posts: 172
jay bob, i like where your head is at. i didn't even think of that.



tonight i checked it, by physically pushing the button, (engine off) and pushing the pedal down as well. both times the button clicked, and then upon release clicked back. it seemed to be functioning correctly.



i just found an article on how to "make" a trans dipstick out of 1/4" poly tubing to check the level. ( unless you have a better cheaper way) i think that may be my next step... we have had the car for just over a year, and never checked the level (im ashamed to say)
__________________
'92 300D 2.5
'99 E300TD
Reply With Quote
  #4  
Old 05-28-2019, 11:42 AM
WTB: 94/95 E320 Wagon
 
Join Date: Oct 2007
Location: Charleston SC
Posts: 2,673
Quote:
Originally Posted by greythunder View Post
the first instance was when merging on the interstate from a cloverleaf interchange, so i was probably going <25 mph. i stomped the accelerator. the engine rpm's increased, way slower than it should have. like seconds slower, then it felt delayed engaging to actually GO.

This sounds like an engine low power issue, not a transmission shifting issue.

I'm not terrible familiar with your transmission other that it is electronically controlled, but on the earlier diesel cars a low engine power problem would often manifest as a transmission shifting problem, because the transmission is set up to work properly with full engine power, and at lower power it would not shift correctly.


The second instance you talk about could be a sticking kick-down switch.
__________________
Respectfully,
/s/
M. Dillon
'87 124.193 (300TD) "White Whale", ~392k miles, 3.5l IP fitted
'95 124.131 (E300) "Sapphire", 380k miles
'73 Balboa 20 "Sanctification"
Charleston SC
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On




All times are GMT -4. The time now is 07:56 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2018 Pelican Parts, LLC - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page