Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help




Go Back   PeachParts Mercedes-Benz Forum > Mercedes-Benz Tech Information and Support > Diesel Discussion

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 10-12-2019, 03:23 PM
CDTurbo001's Avatar
Registered User
 
Join Date: Oct 2017
Location: Campbellsville, KY
Posts: 188
ACC2 woes

1982 300D: Any time "O" is selected on the climate control or the key is turned off, the only way the fan will come back on is by selecting Defrost. After that, the fan works normall in all modes until you hit "O" or key-off.

Also, the (new) A/C compressor was working well but has now stopped coming on at all. Checked the relay, both switches on the receiver/dryer, etc. - all circuitry under the hood seems intact and it will only come on when I jump the 87/30 terminals of the relay.

I've swapped out the climate amp and "button box" (control head) to no avail.

Any help is appreciated!
__________________
'82 300CD
"Pearl", the very first turbo diesel 123 coupe
Totaled 11/23/18, rebuild in progress.
'85 300TD, "Artemis".
'78 300D euro, "Ol' Red", mostly retired.
'85 300D, "Gandalf".
Reply With Quote
  #2  
Old 10-12-2019, 03:33 PM
dude99's Avatar
Registered User
 
Join Date: Nov 2009
Location: Vancouver, BC
Posts: 1,420
So, just to cover bases. You are aware that there is a temp switch which won’t let the blower come on until the engine reaches a minimum temp (I think 40*c???). The defrost button will over ride this.
Reply With Quote
  #3  
Old 10-12-2019, 03:35 PM
CDTurbo001's Avatar
Registered User
 
Join Date: Oct 2017
Location: Campbellsville, KY
Posts: 188
Nope, never heard of that. Where's this switch located?
__________________
'82 300CD
"Pearl", the very first turbo diesel 123 coupe
Totaled 11/23/18, rebuild in progress.
'85 300TD, "Artemis".
'78 300D euro, "Ol' Red", mostly retired.
'85 300D, "Gandalf".
Reply With Quote
  #4  
Old 10-13-2019, 11:33 AM
vwnate1's Avatar
Diesel Dandy
 
Join Date: Nov 2005
Location: Sunny So. Cal. !
Posts: 4,629
Post

That's not right ~ every Klima II equipped W123 I've had will run the fan with the engine off or cold , it just takes a few moments for the control to begin it turning after you turn the key on .

Most often the fan motor's brushes are worn out, easy to replace, you'll need a soldering iron .
__________________
-Nate
1982 240D creampuff 370,000 miles
1978 300CD back from the dead&1980 300CD ~ SOLD
1984 300CD KEEPER ! 440,XXX miles
1984 Euro 300TD Fully optioned SWMBO's
1974 350SLC 4 speed stickshift SOLD & missed
Krazy Kommie Ural Motos (3)
BMW Moto R60/6 Barn Find, 8,000miles
1959 VW #113 Deuxe Beetle, 36hp engine, stock
Junk, Rust, Arthritis, Crushed Spine,Broken Neck&Back
Memories, Peace Of Mind
facts & reality don't change because you can't handle them
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On




All times are GMT -4. The time now is 05:18 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2018 Pelican Parts, LLC - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page