Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help



Go Back   PeachParts Mercedes-Benz Forum > Mercedes-Benz Tech Information and Support > Diesel Discussion

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 02-23-2020, 08:49 PM
nyko46's Avatar
Registered User
 
Join Date: Jan 2004
Location: Rowlett - Texas - USA
Posts: 493
Question Glow Plugs Location - OM642

As I wrote in previous post, I am having an issue with glow plugs on my 2008 E320 Mercedes Benz Bluetec.
Getting a warning about glow plug/glow plug controller on my dash board, I decide to replace the controller and at the same time check the conditions of the glow plugs. Following the glow plug number 1-6 on the female connector from the controller,I found the number 5 as a bad GP.
Now I don't know how are the GP sequence numbers in the engine. How are they numerically located in the engine cylinder head looking the engine from the front of the car?
Also I removed one GP to check the part number in order to buy the correct plug and found all these numbers engraved on it:

CZ 302 7V K72 MK
A 001 159 57 01
NGK

It is a 8 mm Thread.


The new controller is a Beru with Made in Germany engraved on it but the cardboard box says Made in Portugal. After installed and take the car for a drive the glow plug warning went away But I still wanting to replace the bad GP.
Please let me know how to locate the #5 GP.
Thanks

__________________
Nyck - TX - USA
Reply With Quote
  #2  
Old 02-23-2020, 09:06 PM
jay_bob's Avatar
Control Freak
 
Join Date: Oct 2011
Location: Columbia, SC
Posts: 3,906
It goes like this

3 6
2 5
1 4
(front)
__________________
The OM 642/722.9 powered family
2014 ML350 Bluetec (wife's DD)
2013 E350 Bluetec (my DD)
2008 ML320 CDI (Older sonís DD)
2008 E320 Bluetec (Younger son's DD)

1998 E300DT sold to TimFreeh
1987 300TD sold to vstech
----------
gone but living on
1983 240D (body to greazzer, engine to t walgamuth)
Reply With Quote
  #3  
Old 02-23-2020, 09:32 PM
nyko46's Avatar
Registered User
 
Join Date: Jan 2004
Location: Rowlett - Texas - USA
Posts: 493
Quote:
Originally Posted by jay_bob View Post
It goes like this

3 6
2 5
1 4
(front)
Thanks Jay
__________________
Nyck - TX - USA
Reply With Quote
  #4  
Old 02-24-2020, 09:48 AM
nyko46's Avatar
Registered User
 
Join Date: Jan 2004
Location: Rowlett - Texas - USA
Posts: 493
Question

In this car, is it supposed to get a "engine light" when one glow plug goes bad?
__________________
Nyck - TX - USA
Reply With Quote
  #5  
Old 02-24-2020, 01:21 PM
jay_bob's Avatar
Control Freak
 
Join Date: Oct 2011
Location: Columbia, SC
Posts: 3,906
Yes my ML320 had the glow symbol and a CEL on one plug failing.

It is important to get this fixed quickly on this engine, they use the glow plugs for far more than starting.
__________________
The OM 642/722.9 powered family
2014 ML350 Bluetec (wife's DD)
2013 E350 Bluetec (my DD)
2008 ML320 CDI (Older sonís DD)
2008 E320 Bluetec (Younger son's DD)

1998 E300DT sold to TimFreeh
1987 300TD sold to vstech
----------
gone but living on
1983 240D (body to greazzer, engine to t walgamuth)
Reply With Quote
  #6  
Old 02-24-2020, 05:35 PM
nyko46's Avatar
Registered User
 
Join Date: Jan 2004
Location: Rowlett - Texas - USA
Posts: 493
Question

Quote:
Originally Posted by jay_bob View Post
Yes my ML320 had the glow symbol and a CEL on one plug failing.

It is important to get this fixed quickly on this engine, they use the glow plugs for far more than starting.
My situation is this: I had the GP warning (symbol) on my dashboard (at the clock) and also the engine light on.
MB mechanic said that the engine light was because the Glow Plug Module was bad and also the DPF was clogged.
I replaced the GP Module and the GP symbol went away but the code was still there. Also a day after replacing the module the engine light also went away and now the car is running like it was before all these issues with DPF, GP module. No more engine light at all.
Today I stopped at Autozone and even with no engine light they still finding codes.
Code P0402 - Exhaust Gas Recirculation Flow Excessive Detected.
Code 0472- Exhaust Pressure sensor low impute
Code P0670 -Glow Plug module Control Circuit.
I had all these codes before doing any work on my car and the car was extremely slow and no power when accelerating.
Should these codes be reset in order to have an accurate reading?
Or should drive more miles to refresh the system?
Car is driving great now but why these codes, specially the GP Module still coming up again?

__________________
Nyck - TX - USA
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On




All times are GMT -4. The time now is 04:48 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2022, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2018 Pelican Parts, LLC - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page