Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help



Go Back   PeachParts Mercedes-Benz Forum > Mercedes-Benz Tech Information and Support > Diesel Discussion

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 06-29-2020, 05:49 PM
Registered User
 
Join Date: Sep 2001
Location: Former New Jersey resident, transplanted to Atlanta
Posts: 378
1999 E300D transmission diagnosis help

Hey guys,

So my wife was driving her 1999 E300D this evening and the check engine light came on and she stated that the transmission wouldn't shift out of a lower gear.

She pulled over, waited a moment and started the vehicle and the transmission shifted fine.

I think this happened twice..... Of course, I will check the fluid level and I replaced the conductor plate and cleaned the shift solenoid about 18 months ago.

I do not have any type of a Mercedes scanner, only an OBD II.

Any suggestions on what I may check or causes for this symptom?

Thank you all in advance.

__________________
Currently Driving
2006 E320 CDI
1999 E300 Turbo Diesl
2002 ML500
1995 E320 Station Wagon


MBs I've owned
1997 E320 Assassinated by Pine Tree
1987 300E Wife Killed Engine
1981 300D Stretch Limo Total Loss
1970 250 Coupe 212,000 mi.
1974 450sel 184,000 mi.
1974 240D 377,000 mi.
1977 300D 204, 000 mi.
1979 280se God Only Knows!
1983 240D 130,000 mi.
1972 220D 280,000 mi.
1983 300SD 244,000 mi.
Reply With Quote
  #2  
Old 06-29-2020, 07:12 PM
Registered User
 
Join Date: Sep 2001
Location: Former New Jersey resident, transplanted to Atlanta
Posts: 378
It has a small leak and over time the fluid level got low

Thanks
Reply With Quote
  #3  
Old 06-29-2020, 08:16 PM
engatwork's Avatar
busy
 
Join Date: May 2000
Location: Soperton, Ga. USA
Posts: 12,685
Did you replace the cable connector sealing bushing when you had it opened up? Fluid wicking up to TCM?
__________________
Jim
Reply With Quote
  #4  
Old 06-30-2020, 08:46 PM
dtf dtf is offline
Registered User
 
Join Date: Jul 2003
Location: South East CT
Posts: 856
had one....been there......I think it is MB first fully electronic transmission?

when you come to a complete stop and shut off the car does it go back to normal when you start it back up?

is the conductor plate you put in an OEM or after market?
__________________
dtf
1994 E320 Wagon (Died @ 308,669 miles)
1995 E300 Diesel (228,000)
1999 E300 Turbodiesel ( died @ 255,000)
2006 Toyota Tundra SR5 AC 4X4 (115,000 miles) rusted frame - sold to chop shop
2011 Audi A4 Avant (165,000 miles) Seized engine - donated to Salvation Army
BMW 330 xi 6 speed manual (175,034 miles)
2014 E350 4Matic Wagon 128,000 miles
2018 Dodge Ram 21,000 miles
Reply With Quote
  #5  
Old 07-01-2020, 07:25 AM
engatwork's Avatar
busy
 
Join Date: May 2000
Location: Soperton, Ga. USA
Posts: 12,685
Wait a minute. Get the code read. Is it actually going into limp mode?
__________________
Jim
Reply With Quote
  #6  
Old 07-01-2020, 08:53 AM
Registered User
 
Join Date: Sep 2007
Location: Calgary Alberta Canada
Posts: 1,349
If it did actually go into limp the only way to get it out of limp is to clear the code with a MB style code reader.
__________________
92 e300d2.5t
Reply With Quote
  #7  
Old Yesterday, 08:30 AM
Registered User
 
Join Date: Sep 2001
Location: Former New Jersey resident, transplanted to Atlanta
Posts: 378
Well guys, the fluid level was low about a quart.

I don't think it went into limp mode as you could shut it off and restart it and everything worked correctly.

Unfortunately, both the conductor plate and the plug were aftermarket Ebay items.

Since I have topped off the transmission fluid, it has not occurred again, however, I am sure that the transmission plug is probably leaking again, it seems to be minor so it may buy me time.

I will insure that when I change it out to get an OEM.

__________________
Currently Driving
2006 E320 CDI
1999 E300 Turbo Diesl
2002 ML500
1995 E320 Station Wagon


MBs I've owned
1997 E320 Assassinated by Pine Tree
1987 300E Wife Killed Engine
1981 300D Stretch Limo Total Loss
1970 250 Coupe 212,000 mi.
1974 450sel 184,000 mi.
1974 240D 377,000 mi.
1977 300D 204, 000 mi.
1979 280se God Only Knows!
1983 240D 130,000 mi.
1972 220D 280,000 mi.
1983 300SD 244,000 mi.
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On




All times are GMT -4. The time now is 03:16 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2020, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2018 Pelican Parts, LLC - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page