Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help




Go Back   PeachParts Mercedes-Benz Forum > Mercedes-Benz Tech Information and Support > Diesel Discussion

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 08-25-2002, 07:28 PM
Ivo Tyl
Guest
 
Posts: n/a
Cool Strange noise in rear of 300SD

After 2 months of my problem,discussed here but many pages back,I am happy to report that the mistery was solved by a simple replacement of rear shock absorbers( not cheaply unfortunately).So if somebody with the same problem,start there,it could save you money.
Reply With Quote
  #2  
Old 08-25-2002, 09:39 PM
billrok's Avatar
Registered User
 
Join Date: Dec 2001
Location: Chicago area
Posts: 242
What was the problem you were experiencing again??
__________________
Orland Park, IL
1985 300SD 215,000 miles
Reply With Quote
  #3  
Old 08-27-2002, 12:20 PM
Ivo Tyl
Guest
 
Posts: n/a
You will probably remember my posted two subjects,where some strange noise was diagnosed with difficulties.Firstly we were thinking that the linkage to the sway bar was the problem.It was not.Then we tried to replace the shockabsorbers and found that it did apparently solved the problem.
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On




All times are GMT -4. The time now is 10:26 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2018 Pelican Parts, LLC - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page