PeachParts Mercedes-Benz Forum

PeachParts Mercedes-Benz Forum (http://www.peachparts.com/shopforum/)
-   Diesel Discussion (http://www.peachparts.com/shopforum/diesel-discussion/)
-   -   350SDL Won't Start -Alarm & Glow plug Module ? (http://www.peachparts.com/shopforum/diesel-discussion/52351-350sdl-wont-start-alarm-glow-plug-module.html)

ezrider 12-13-2002 12:54 AM

350SDL Won't Start -Alarm & Glow plug Module ?
 
Recently replaced glow plugs and glow plug module, all was well for about a week.

Today would not start as usual, after trying about 10 times, with smoke coming out of exhaust on each try, it finally started and ran very rough until it warmed up a little, either it was flooded when it started or the glow plugs are not working, I then drove the car, after the first stop it restarted but the alarm kicked in with horn blowing and lights flashing, found the alarm module on the passenger side lower firewall and unplugged lower plug on alarm module, it then restarted fine several times during the day, without the alarm kicking in, after sitting for 6 hours it was very hard to get it restarted again, unplugged the harness plug going to the glow plugs on the glow plug module and with the key on I measure 12VDC going to each glow plug at the module.

I am original owner of the car so I know it's history.

Any ideas would be greatly appreciated.

Thank you.


All times are GMT -4. The time now is 09:10 AM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2022, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2018 Pelican Parts, LLC - Posts may be archived for display on the Peach Parts or Pelican Parts Website