Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help



Go Back   PeachParts Mercedes-Benz Forum > Mercedes-Benz Tech Information and Support > Diesel Discussion

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 01-05-2003, 08:19 AM
thebern's Avatar
Registered User
 
Join Date: Jan 2002
Location: Knotts Island, NC
Posts: 382
creaking front suspension

The front suspension creaks, snaps pops and grumbles when the weather is cold . This is new this winter as it didnot do this last year. Of particular concern is that when straightening the steering wheel after a left turn there is a distinc pop or grumble from the front left. Could this be a shock going bad, a wheel bearing or steering knuckle? I have used the search and have raised the car and checked the suspension, it all seems okay to me but I'm not exactly a front end guru!


thanks thebern

__________________
1982 240D 313,000 (4 speed)
1984 300CD 172,483
1985 German Shepherd Dog -Lacey- R.I.P.11/04/05

Hood Stars, Wrist Crowns and Obsession Dobs
Reply With Quote
  #2  
Old 01-05-2003, 09:08 AM
RYT867
Guest
 
Posts: n/a
Just wondering if you saw my Mickey Mouse post, I am getting weird noises from the rear of my wagon only on hard right turns, can't figure out what is causing it. Perhaps your observation on temperature and weather may hold true for me also.
Reply With Quote
  #3  
Old 01-05-2003, 10:59 AM
LarryBible
Guest
 
Posts: n/a
It is doubtful that the shocks are solely responsible for such noises.

The only way you will know is to use to raise the front of the car and use the "three P's," Push, Pull and Pry. Do this to all ball joints, control arm bushings and track rod mounts.

To check the lower ball joints you will need to put the floor jack under the lower control arm. For most everything else, you will need to support the chassis, preferably with jack stands under the unibody front "frame rails."

Good luck,
Reply With Quote
  #4  
Old 01-05-2003, 02:02 PM
Registered User
 
Join Date: Oct 2001
Location: Western Mass.
Posts: 324
Had the same front end problem on my last two cars and both times it turned out to be worn sway bar bushings. You could see some rusty stuff coming from around the bushings. I know rust from rubber? No it was from the bar. BTW the metal on both bars was also worn some.
Good Luck

__________________
Ricali

03 C240 4matic wagon
95 300E 234,000
7 prior 240;s 5 still going
81 300sd gone
65 230sl gone
49 Studebaker Champion
90BMW convert.167,000
60 Dodge D-100
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On




All times are GMT -4. The time now is 12:15 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2023, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2018 Pelican Parts, LLC - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page