Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help



Go Back   PeachParts Mercedes-Benz Forum > Mercedes-Benz Tech Information and Support > Diesel Discussion

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 01-31-2003, 10:03 PM
iownsnoopy
Guest
 
Posts: n/a
Question scary transmission

my 1983 300 sd started shifting really slow but really smooth about 2-3 months ago. suddenly just 2 days ago after driving home the transmission started slipping very badly, i just barely got my baby home. the dealership did a repair on the transmission and replaced the piston.

the mechanic indicated that the shifting may still be slow and race a little between shifts and suggested that i replace the vacume modulator.

is this a good idea? will it make the trans last longer?

Reply With Quote
  #2  
Old 01-31-2003, 10:37 PM
grey500se's Avatar
Registered User
 
Join Date: Nov 2001
Location: VA 20 miles west of D.C.
Posts: 245
I've had three Mercedes all had the same rev up in between shifts, if the kickdown cable is too tight it would shift late but not slip, too loose would make it shift too early and it will slip, I suggest taking it to a Mercedes specialist they can get a the adjustment perfect, very common problem with Mercedes, as for it being safe the way it is, I would say yes, I would rather have it the cable loose and shift early and race in between shifts, another thing at about 80-120mph the trans will not slip, if the cable is tight it will slip at high speeds, I would leave it, my 500SE does the same thing, I even changed the transmission, same thing, my boss's 300SDL has a brand new trans, it does the same thing, more when the car is cold, I usually keep it in 3rd instead of Drive gear until I reach 60 or so mph, the vacuum to the module sometimes leaks causing shifting problems, have it checked and replaced, its not much for that service
__________________
1994 Ford Taurus SHO
1999 Kawasaki Ninja ZX9R
Reply With Quote
  #3  
Old 02-01-2003, 02:41 AM
haasman's Avatar
Registered User
 
Join Date: Jun 2001
Location: San Francisco, CA
Posts: 3,097
Have you read this? Trans slip repair
__________________
'03 E320 Wagon-Sold
'95 E320 Wagon-Went to Ex
'93 190E 2.6-Wrecked
'91 300E-Went to Ex
'65 911 Coupe (#302580)
Reply With Quote
  #4  
Old 09-10-2008, 12:12 PM
Registered User
 
Join Date: Sep 2008
Posts: 1
I just bought a 1986 300SDL. When I start off the trans shifts into 2nd before the tires turn half way around. I is in 4th by 10 mph. I adjusted the cable tight, loose , all inbetween , and also took it off . It does not change shift points. I must manually shift trans. If I am on a hill it shifts into second as soon as the car moves a foot then the car is a dog to make up hill. Help!!

Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On




All times are GMT -4. The time now is 06:27 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2018 Pelican Parts, LLC - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page