Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help



Go Back   PeachParts Mercedes-Benz Forum > Mercedes-Benz Tech Information and Support > Diesel Discussion

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 03-23-2003, 10:57 PM
Registered User
 
Join Date: Jan 2003
Location: Eastern NC
Posts: 338
Unhappy Help! battery light still on!

1976 240d w115.
The battery light started coming on slightly a couple of months ago.
I searched and asked and the most common suggestion was ground and alternator. I checked and cleaned the ground under the battery tray and kept driving the car and never had any trouble with the car starting or running although the light stayed on. (Dimm when running and brighter when idling and even brighter when you turn the headlights off).
I took the alternator out of the parts cars to be rebuilt but did not try to install it until the battery light started staying brighter even when running.
Well, I installed the new(rebuilt) alternator with a new belt today and the battery light is as bright or brighter than ever.
Does anybody have any ideas?
Thanks for the help.

__________________
Ncnetman
1959 Chev 3100 Fleetside
1965 Mustang
1968 Torino GT fastback
1969 Ranchero
1974 240d 4-speed -for sale
1976 240d fresh paint- on hold
1978 300cd fresh paint and new rearwindshield rubber
1990 6.2 Suburban 194k-getting a 6.5 turbo
2008 Duramax Silverado
2015 VW Passat TDI
Reply With Quote
  #2  
Old 03-24-2003, 08:00 AM
Registered User
 
Join Date: Jan 2003
Location: Eastern NC
Posts: 338
Talking Help please

I'm sure hoping someone out there has run into this problem before and has a few suggestions.
Should I move this thread to the vintage or tech board?

Thanks
__________________
Ncnetman
1959 Chev 3100 Fleetside
1965 Mustang
1968 Torino GT fastback
1969 Ranchero
1974 240d 4-speed -for sale
1976 240d fresh paint- on hold
1978 300cd fresh paint and new rearwindshield rubber
1990 6.2 Suburban 194k-getting a 6.5 turbo
2008 Duramax Silverado
2015 VW Passat TDI
Reply With Quote
  #3  
Old 03-24-2003, 11:42 AM
yel_low
Guest
 
Posts: n/a
i think your rebuilt alternator is your problem...


what have u replaced in the alternator when u rebuilt it?


have u tested if the alternator lamp goes out if u put it on +on battery? and it lights bright when u put it on ground?

does the alternator lamp light up when u turn the ignition on? of course before u start engine... ?


check these things and post a reply and i will try help u out with your problem.

Reply With Quote
  #4  
Old 03-24-2003, 09:53 PM
Registered User
 
Join Date: Jan 2003
Location: Eastern NC
Posts: 338
Smile tester

I will get a tester tomorrow and check those items and a few more and report back.
Thanks

__________________
Ncnetman
1959 Chev 3100 Fleetside
1965 Mustang
1968 Torino GT fastback
1969 Ranchero
1974 240d 4-speed -for sale
1976 240d fresh paint- on hold
1978 300cd fresh paint and new rearwindshield rubber
1990 6.2 Suburban 194k-getting a 6.5 turbo
2008 Duramax Silverado
2015 VW Passat TDI
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On




All times are GMT -4. The time now is 07:29 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2023, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2018 Pelican Parts, LLC - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page