Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help



Go Back   PeachParts Mercedes-Benz Forum > Mercedes-Benz Tech Information and Support > Diesel Discussion

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 03-25-2003, 12:09 PM
James McClain
Guest
 
Posts: n/a
Post 300D engine install

I have a metallic blue 1980 300D, Merc. the engines compression was low in two cylinders, so I replaced the engine with a 1979 issue 300D M. engine. The 79 engine has different spark plugs (filament type, and relay harness, and relay, and vacuum module on the top of the injector). I have both harnesses, and relay boxes, and injectors. How should I resolve the glow-plug-harness, relay problem especially. Thanks in Advance. Sure could use some help with this! James

Reply With Quote
  #2  
Old 03-25-2003, 09:04 PM
Moderator
 
Join Date: Dec 2001
Location: Southern California, U.S.A.
Posts: 8,538
I would suggest re-posting this in the Diesel section.

It is the most active forum on this site, and there are many people who I'm sure can answer your question.

__________________
Paul S.

2001 E430, Bourdeaux Red, Oyster interior.
79,200 miles.

1973 280SE 4.5, 170,000 miles. 568 Signal Red, Black MB Tex. "The Red Baron".
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On




All times are GMT -4. The time now is 06:53 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2023, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2018 Pelican Parts, LLC - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page