Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help



Go Back   PeachParts Mercedes-Benz Forum > Mercedes-Benz Tech Information and Support > Diesel Discussion

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 05-01-2003, 10:03 PM
mszablowski
Guest
 
Posts: n/a
84,300D a/c compressor

This car is new to me, when the harness connector is plugged back on to my air cond. compressor and I start the engine I hear it clicking on. questions: any known problems with this particular year/model air cond system and is it possible to have the compressor rebuilt or is it a core swap at a local parts store. The air does not come on cold, I figure the system needs an overhaul, but Im also hearing a grinding sound out of it-not good. so I leave it unplugged. What's the best course of action on this. I would like to get this working before the really hot weather gets here. Another problem I'm having is with the cruise control, not working, I can see the actuator move somewhat by the engine but thats about it, nothing while I'm driving, could this be a sign that its just the amplifier inside the car and where is it, under the dash or behind the speedometer? Any suggestions? thanks
again.

Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On




All times are GMT -4. The time now is 04:16 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2020, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2018 Pelican Parts, LLC - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page