PeachParts Mercedes-Benz Forum

PeachParts Mercedes-Benz Forum (http://www.peachparts.com/shopforum/)
-   Diesel Discussion (http://www.peachparts.com/shopforum/diesel-discussion/)
-   -   Shut Off And A/C Vacuum Problem (http://www.peachparts.com/shopforum/diesel-discussion/69280-shut-off-c-vacuum-problem.html)

Abner Mality 07-04-2003 04:29 PM

Shut Off And A/C Vacuum Problem
 
I need serious help; tried a search, but could not find a related post. Last night, the ignition switch failed to shut off the engine on my '80 300SD. Used the shut off lever under the hood, and knew to get up early this morning and check the vacuum lines. Nothing obvious loose or broken, so I figure I have a stoppage somewhere. On my way into town, I noticed, too, that my A/C center vents weren't issuing any air. I was further convinced of a vacuum problem. About a half-hour later, I started back home, and the A/C would not run at all. The compressor isn't kicking in, and no air comes from any vents. I know the old auto temp system has vacuum lines going into the back of the unit, so I now figure there is a problem with that system, but vacuum related just like the shut off. My door, trunk, and fuel door locks still work. Can someone point me in a direction that will get me to a successful fix for this problem? The heat index here in Northeastern Arkansas is 99 today, and I hate to be hot.

Thanks in advance for any and all help

LarryBible 07-04-2003 04:46 PM

The most common cause of the problem you describe is knocking vacuum lines loose when changing the oil filter.

Since you said you've checked the lines, then it's now time to check the source. Remove one of the vacuum lines that connect to one of the tees on the main vac line that goes from the pump to the brake booster. Start the car and put your finger over the tee to see if there is plenty of vacuum. If not, then it's time to put a diaphragm in the vacuum pump.

If you do rebuild the pump, make sure to check the roller in the pump. If it breaks it can get down into the engine and destroy it.

Good luck,

ATLD 07-05-2003 02:53 AM

You can also purchase a MityVac so you can test the different lines/actuators for their ability to hold a vacuum; ones that don't should be replaced. You can also quantitatively test to see what vacuum your engine driven pump can pull, so you have a better idea about it's condition. This is the easy way to make sure that everything is properly working and connected, if you are scrupulous. Also, you can purchase kits for different sources that sell all the litttle replacement vacuum connections throught the car. Might be a good time to do so, if you find that it's the rubber that's the problem and not a loose line. Finally, if for some reason you want to change out the start-stop pneumatic actuator for the IP, don't! This is the one very precise and delicate job that I believe should be left to qualified shops with insurance... as we find too many occurances where the engines literally run-away because of a slight misalignment etc.

ATLD

Abner Mality 07-07-2003 05:00 PM

To Larry Bible: Thanks for the info you provided. I follow your posts, and admire your knowledge. However, if my vacuum pump has failed, as you suggest, wouldn't I be experiencing shifting problems, and a lack of power boost for the braking system? My tranny still shifts as before, and the power brakes work just fine. I'm headed out to get a Mighty-Vac so that I can begin testing for leaks in this 23-year old system. I am sure there will be some in the most inconvenient of places. I have moderate skills -- certainly not a beginner -- and am looking to do more of my own maintenance to save as much on labor as possible. If you have any further thoughts to simplify my hunt, please jump in.

Rick Miley 07-07-2003 05:19 PM

Connect the Mityvac to the brown line going to the injection pump shutoff and pump it down. It should move the stop lever, and it should hold vacuum. If not, the shutoff diaphram is bad.

If that works, reconnect the line you just tested and connect the Mityvac to the other brown line that goes into the firewall. This one supplies vacuum to the key switch. With the switch in the off position you should be able to pump it down and again, have the stop lever go down and have it hold vacuum.

To test the AC system connect the Mityvac to the green line that goes into the firewall. It should hold vacuum. I can't help you any further than that because my 240D has a different system than yours.

The door locks are supplied by the two yellow lines. I wrote an extensive post last week describing how to diagnose leaks in that system.

Abner Mality 07-08-2003 06:25 PM

Problem Solved!!!
 
Thanks, all, for the advice. Purchased the little My-T-Vac, and traced the vacuum leak to a cracked, and very brittle vacuum check valve. I have temporarily plumbed around it, and have ordered a complete replacement set from Phil at Phastlane.

Pree-shee-ate it.....

Abner Mality


All times are GMT -4. The time now is 07:40 PM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2020, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2018 Pelican Parts, LLC - Posts may be archived for display on the Peach Parts or Pelican Parts Website