Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help




Go Back   PeachParts Mercedes-Benz Forum > Mercedes-Benz Tech Information and Support > Diesel Discussion

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 07-06-2003, 11:14 AM
Registered User
 
Join Date: Jul 2003
Location: Sarasota, FL
Posts: 6
Diesel Fuel Pump

My 1985 300TD just saturated a secondary filter again - after just 3 weeks. I cut the filter open, and I don't see signs of it being particularly saturated, but the car died suddenly, and wouldn't start until the filter was replaced. I suspect a weak fuel pump. How do I test before spending $200 on a new one?
Thanks
Reply With Quote
  #2  
Old 07-06-2003, 11:39 AM
Registered User
 
Join Date: Sep 2001
Location: central Texas
Posts: 17,277
Cutting open the filter is good practice... but you need to go the next step and try to figure out WHAT is filling it up....
Do you have signs of algae ?
Do you use a clear 90 degree inline filter ? if so what does it look like ? Have you used any Diesel Doctor or Biocide or something like that in the last ten years ? Have you changed the other filters in your system ? Does your car have a filter in the fuel tank ? and have you ever changed it ?
Reply With Quote
  #3  
Old 07-06-2003, 01:09 PM
Registered User
 
Join Date: Jul 2003
Location: Sarasota, FL
Posts: 6
doesn't seem like anything is plugging up the filter. It seemed cleean when I opened it. That is why I suspect the fuel pump. The primary filter is clear, but I have never checked or changed the tank filter (if there is one).
Reply With Quote
  #4  
Old 07-06-2003, 01:44 PM
Registered User
 
Join Date: Sep 2001
Location: central Texas
Posts: 17,277
"just saturated a secondary filter again " What does that mean?
Reply With Quote
  #5  
Old 07-06-2003, 02:29 PM
Registered User
 
Join Date: Jan 2000
Location: PA
Posts: 5,440
Jens_Benz,

Yes, What does saturated a secondary filter mean????

As far as I'm concerned, the filter is always saturated with fuel.

There is a fuel strainer in the fuel tank. If it starts to get clogged it can make strange things happen. It would be to your advantage to check the in tank strainer before you monkey with the fuel pump. The strainer can be cleaned and does not have to be replaced unless it has a hole in it. It screws out from the bottom of the tank so you have to empty the fuel tank first.

P E H
Reply With Quote
  #6  
Old 07-06-2003, 03:05 PM
Registered User
 
Join Date: Jul 2003
Location: Sarasota, FL
Posts: 6
I was driving at about 30mph, and the car just died. No warning. It was fine, and 30 seconds later, it stopped. I tried blowing into the fuel line to clear it, but that didn't help. When I replaced the secondary filter (cartrige type) the car started fine and ran OK. I tow my boat with this car, and there was no indication the day before that there was any trouble with the boat in tow. Like I said, the problem apears to be the cartrige filter, but when I cut it open, I didn't find it to be plugged with a bunch of junk as I expected.
Reply With Quote
  #7  
Old 07-07-2003, 01:21 AM
Registered User
 
Join Date: Jul 2003
Posts: 15
I'd at least consider flushing the tank. Then when it's empty you can tap it to see if anything -really- big is loose.

Actually had a section of metal rust away and float over a pickup, causing this to happen at lower throttle but higher fuel flow (ie, under load - like towing) with a v. old truck.

Just a suggestion. You'd probably find the problem doing this anyway.
Reply With Quote
  #8  
Old 07-07-2003, 02:06 AM
Registered User
 
Join Date: Jan 2001
Location: oregon
Posts: 2,013
fuel pump? I'll bet a dime you have water in your tank...........
William Rogers........
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On




All times are GMT -4. The time now is 12:47 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2018 Pelican Parts, LLC - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page