Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help




Go Back   PeachParts Mercedes-Benz Forum > Mercedes-Benz Tech Information and Support > Diesel Discussion

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 09-17-2003, 01:57 PM
unkl300d's Avatar
Registered User
 
Join Date: Jul 1999
Location: San Francisco, Ca
Posts: 2,295
'94 S350D has starting problem-help-dirty contact?

Hi, my friend's S350D (with recently replaced engine )
has this probem upon turning the ignition on:
dummy lights will all go dim except for the SRS light which stays bright.
The glow plug light does not go on at all.Car won't start.
When he tries it for the second time, no dummy lights go on except the SRS and again the glow plug light does not go on.
The car won't start.
If he wiggles the steering wheel and shifter for 5 minutes or more
or waits an hour thereafter, the car does turn over.

No idea how frequent this problem is.
He suspects the relay at the shifter which prevents the car from starting unless it is in park.
I opined that it might be the glow plug relay (what do I know?? )
Anyway, any opinions out there???

Thanks


He is also looking to re-chrome his rims or buy stock ones I will post this on the wheels section.
__________________
1979 300D 199 K miles
1995 C280 95 K miles
1992 Cadillac Eldorado Touring Coupe 57K miles
********************
1979 240D 140Kmiles (bought for parents) *SOLD.
SAN FRANCISCO/(*San Diego)
1989 300SE 148 K miles *SOLD
Reply With Quote
  #2  
Old 11-07-2003, 05:19 PM
nhodges's Avatar
Registered User
 
Join Date: Nov 2001
Location: Northern VA
Posts: 461
Was there ever an answer to this? I have an SRS and glow plug problem. I replaced all six glowplugs with Brand new MB plugs. Now it won't glow at all. I have re-checked the connections and looked at the relay box. It is put together with torx screws. Is there a fuse inside or is it fused some where else?

2. My SRS light blinks when the switch is first turned on, then it stays on for 3-5 minutes before it goes out. Anyone know what's going on here. What is the fix?
__________________
N. Hodges
1994 S350
1987 300 SDL (for sale)
Reply With Quote
  #3  
Old 11-07-2003, 08:01 PM
Registered User
 
Join Date: Feb 2000
Location: Columbus Ohio
Posts: 709
Sounds like an electrical issue to me...maybe the ignition switch is bad?
I think MB had already solved the instrument cluster shorting problems by 1994 model year...but you might want to ask abiut this...any dealer should know about this issue...they replaced many clusters in 1992-93 140 cars



Warren
1992 300SD 168K
Columbus Ohio
Reply With Quote
  #4  
Old 07-04-2006, 12:07 AM
Registered User
 
Join Date: Oct 2001
Location: around Charlotte NC
Posts: 578
OK, Now my car is doing this...

Folks,

Same symptoms as the initial poster. A '93 300 SD. Turn the key and only the SRS light is illuminated - no other idiot lights including the glow system. Not even a hint of the starter or soleniod attempting to work. Horn, lights, interior lights all look fine and are full strength, so I don't suspect a battery connection. It ran 20 minutes before this happened.

I didn't see a solution in this string, but I'm suspecting ignition switch. I've spent about 30 minutes of wiggling the ignition, transmission in and out of park, Suggestions? Troubleshooting techniques?

Thanks,
Chuck
Reply With Quote
  #5  
Old 07-04-2006, 12:20 AM
unkl300d's Avatar
Registered User
 
Join Date: Jul 1999
Location: San Francisco, Ca
Posts: 2,295
S350d

The guy with the S350D got it fixed sometime ago.
Simple solution. I think it was the shifter relay but I'll ask him and report back later.

BTW he is now selling this car for about $14K<. chassis has 120K miles and 100% new engine has about 17K. He has too many cars, snowmobiles etc... and now does more off road sports etc...

more later....
__________________
1979 300D 199 K miles
1995 C280 95 K miles
1992 Cadillac Eldorado Touring Coupe 57K miles
********************
1979 240D 140Kmiles (bought for parents) *SOLD.
SAN FRANCISCO/(*San Diego)
1989 300SE 148 K miles *SOLD
Reply With Quote
  #6  
Old 07-04-2006, 07:23 PM
Registered User
 
Join Date: Oct 2001
Location: around Charlotte NC
Posts: 578
update

Folks,

Here's an update and a chance to bump to the top again.. It was very hot yesterday, probably 95*, and stayed warm well into the night. The first no-start was about 6pm. At 10 pm still no start. This morning all was fine. It was about 90 today and all stayed fine, so maybe its that last 5*.

Please let me know know if you have seen this symptom and what your fix or diagnosis process was. The idea of that transmission interlock relay is a good possibility and easier than the ignition switch.

Thanks,
Chuck
Reply With Quote
  #7  
Old 07-06-2006, 12:31 AM
unkl300d's Avatar
Registered User
 
Join Date: Jul 1999
Location: San Francisco, Ca
Posts: 2,295
here's the rebound...the guy said that the car engine would shut off after he would depress the brake pedal. happened after the car was warm and driven alot. could not turn car back on until he let the car sit for a while.

turned out to be the ignition switch which had a short and would heat up.
had ignition replaced. approx $90 parts $150 labor.
no problems now. was not the trans selector switch.
__________________
1979 300D 199 K miles
1995 C280 95 K miles
1992 Cadillac Eldorado Touring Coupe 57K miles
********************
1979 240D 140Kmiles (bought for parents) *SOLD.
SAN FRANCISCO/(*San Diego)
1989 300SE 148 K miles *SOLD
Reply With Quote
  #8  
Old 07-06-2006, 10:38 PM
Registered User
 
Join Date: Oct 2001
Location: around Charlotte NC
Posts: 578
Thanks

for taking the time to find out. This happened once a long time ago and never again until Monday ( when it was very hot). Tuesday it was hot again and no issues. Wednesday cooler and no issues. Today even cooler (rain) and it failed 3 times but was able to get it started after multiple retries. Going in on Monday to have it looked at.

Amusing side point. After about 3+ years of dieseling, I get in my gas powered van to go back to work. Turn the key to accessory, admire the idiot lights for a while ( no "start it now you idiot" light). Then decide to turn the key to start. I kinda like that moment pause in starting to brace for playing in traffic.

8)

Chuck
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On




All times are GMT -4. The time now is 09:55 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2018 Pelican Parts, LLC - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page