Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help



Go Back   PeachParts Mercedes-Benz Forum > Mercedes-Benz Tech Information and Support > Diesel Discussion

Reply
 
LinkBack Thread Tools Display Modes
  #16  
Old 11-01-2003, 12:35 AM
84W123DT
Guest
 
Posts: n/a
Picture 4 of 4

Attached Thumbnails
Automatic Climate Control  Sign of Fatique?-acc-hose-replacement-003.jpg  
Reply With Quote
  #17  
Old 08-09-2007, 01:54 PM
Ron59b
 
Join Date: Aug 2007
Location: Richmond, Virginia
Posts: 485
Where on my car can I find the mono valve. I am having the same problem as Ken with the heater blows full hot 90% of the time. It does not seem to matter what the CC dial is set on. Sounds like I need to check this item out. I have done the form tube replacement.

I am also open to any other suggestions?

Ron
Reply With Quote
  #18  
Old 08-09-2007, 03:31 PM
Craig
Guest
 
Posts: n/a
Quote:
Originally Posted by ron59b View Post
Where on my car can I find the mono valve.
I assume we a talking about an 83 300D, the monovalve is on the firewall right next to the battery, it has two heater hoses and a wiring connection.
Reply With Quote
  #19  
Old 08-10-2007, 04:40 PM
Ron59b
 
Join Date: Aug 2007
Location: Richmond, Virginia
Posts: 485
Thanks man (Mono valve)

Hey Craig,

Thanks for the speedy reply. I will be checking my mono valve this weekend. Yes my car is a 1983 300 D Turbo. I am having the problem with the heat blowing full heat most of the time.Do you have any other suggestions. Anything I should know about checking this thing?

Ron
Reply With Quote
  #20  
Old 08-10-2007, 04:48 PM
Craig
Guest
 
Posts: n/a
I would start by checking fuse #14, if it is blown the monovalve will be fuly open. On the valve itself, you can open the top and make sure the diaphragm is not damaged. The internals look like this, and you can buy a repair kit if this is the problem:

Mono valve links thread


.

Last edited by whunter; 01-28-2014 at 12:38 AM. Reason: replaced dead link
Reply With Quote
  #21  
Old 08-10-2007, 06:08 PM
rrgrassi's Avatar
mmmmmm Diesel...
 
Join Date: Jun 2006
Location: Royse City Tx
Posts: 5,171
RonB,

Please update your signature in the "User CP" with your car's info. It makes answering the questions a lot easier.
__________________
RRGrassi


70's Southern Pacific #5608 Fairmont A-4 MOW car

13 VW JSW 2.0 TDI 193K, Tuned with DPF and EGR Delete.

91 W124 300D Turbo replaced, Pressure W/G actuator installed. 210K

90 Dodge D250 5.9 Cummins/5 speed. 400K
Reply With Quote
  #22  
Old 08-13-2007, 03:55 PM
Ron59b
 
Join Date: Aug 2007
Location: Richmond, Virginia
Posts: 485
Done

Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On




All times are GMT -4. The time now is 06:33 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2024, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2018 Pelican Parts, LLC - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page