Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help




Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Diesel Discussion

Reply
 
LinkBack Thread Tools Display Modes
  #16  
Old 11-22-2003, 04:20 PM
Registered User
 
Join Date: Sep 2001
Location: central Texas
Posts: 17,027
So you are saying you did not change out the oil to match the r-134a ?
Reply With Quote
  #17  
Old 11-25-2003, 02:11 PM
Registered User
 
Join Date: Jul 2002
Posts: 1,141
I'm not sure where the marginal call is on W123 a/c systems.

Mine has always been great here in Texas. R12 car of course-it's cream exterior! I've always had good luck with rebuilt hoses- my car is running several sections right now=)

For you guys - check your evaporators. To say you have poor performance ussually means something is wrong. If the pressures are correct, and the vacuum system controls is fuctioning. Pull the a/c fan. Reach in and feel the evaporator. Is it clean? Dirty? Oily and nasty? They make cleaners for those cores with a flexible hose so you can do it without removal.

Oil would be a sign of a leak!


Michael
__________________
Michael McGuire
83 300d
01 vw A4 TDI
66 Chevy Corsa
68 GMC V6 w/oD
86 300E
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On




All times are GMT -4. The time now is 04:59 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page