Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help




Go Back   PeachParts Mercedes-Benz Forum > Mercedes-Benz Tech Information and Support > Diesel Discussion

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 12-05-2003, 10:23 AM
meh1998
Guest
 
Posts: n/a
'83 SD - No power starting off....

have a 1983 SD with 197k miles on it. It starts fine, although the idle is somewhat rough, but has no power to drive off until it warms up & then I have to downshift to get the car up to speed.

Once I'm at a higher speed the vehicle seems to be ok - I can do
85 mph all day.......


__________________
Reply With Quote
  #2  
Old 12-06-2003, 12:30 AM
Registered User
 
Join Date: Jan 2001
Location: oregon
Posts: 2,013
Boy thats right on! I was very dissapointed in my 81 SD when I first bought it as it did not seem much faster than my manual 240D. But after adjusting the valves ,changing both fuel filters,new glow plugs and a good cleaning of the banjo fitting the difference was night and day.......
WilliamRogers..........
Reply With Quote
  #3  
Old 12-06-2003, 08:17 PM
meh1998
Guest
 
Posts: n/a
I posted to "Tech Help" originally & then thought I should post to the "Diesel Discussion" section - so now I have two posts on the same issue (newbie error)

I checked and the switchover valve has been bypassed. I plugged the vacuum line to the EGR & then turned the ALDA screw CCW
1 turn (virgin screw).

I had no smoking at all on idle....drove off & the car actually went fast! Stopped at market & decided to then drive at highway speed. Car then started having problems with power at high end.

Came home....cleaned banjo bolt (which was loose), blew air through tube....

Now I'm back to where I started with no low end power.....haven't tried yet at highway speeds....
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On




All times are GMT -4. The time now is 02:18 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2018 Pelican Parts, LLC - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page